OpenWrt Proxmox script

Did connecting your notebook not work?

Yes, that should be WAN, but since you configured three NICs for OpenWrt, I'm unsure which one has become WAN. OpenWrt defaults to a DHCP client for WAN, but your output from ip addr did not list any IP address on the WAN interface.

it did work last time, I setup pfsense, but I don't have a USB-ethernet adapter right now.
third interface was by mistake.
this mini PC has only two NICs.

current setup


Let's go one step back: What is your actual goal?

You can, of course, reconfigure the LAN interface to get an IP in the 192.168.8.0/24 range, but since OpenWrt provides a DHCP server by default, you will probably end up having two DHCP servers in your network.

right now I just want to set up this OpenWRT VM for testing 24.10.
so I am fine with two DHCP servers for testing OpenWRT only. this isn't for production use right now.

Well, then you're done. OpenWrt is up and running.

but I need to access Luci from WAN side/ without plugging in the second NIC.

Well, if you have a single nic, it will be lan by default - if you changed that, you will have to change the firewall as well.

config rule                  
        option src 'wan'      
        option name 'http from WAN'
        option proto 'tcp'
        option dest_port '80'
        option target 'ACCEPT'
                          
config rule                  
        option src 'wan'      
        option name 'https from WAN'
        option proto 'tcp'
        option dest_port '443'
        option target 'ACCEPT'

1 Like

I can't paste this in OpenWrt VM somehow.

current config

Paste is not a feature within the lxc console of Proxmox VE itself. To use paste, you have to use a telnet/ssh client like Visual Studio or something.

You can paste into the Proxmox VE server console, just not the lxc client console.

1 Like

this is a chicken and egg issue.
I am looking for access from the wan side/proxmox side.

should I ssh from Proxmox VE itself?

I cannot answer that about ssh from the PVE shell but my personal preference is to use MS Visual Studio as the SSH client on my desktop. I used to be big into Putty as the ssh application of choice but VS can do a lot so I switched.
I do not ssh from the PVE instance to anywhere. Cant say it is right or wrong, just not how I go about ssh access.
From the lcx interface you could just manually type out what you showed, that is not an overly large amount of typing.

I was able to ssh from PVE shell.
but the only text editor available is vi in which I am not proficient enough.

https://www.cs.colostate.edu/helpdocs/vi.html

should I add those rules before this

Updated : Forgot you are trying to edit from within OpenWRT.
This is easier.. This is where I got my steps and they work great.
Specifically post 8
Post 8 for WAN web access and nano editor install

no internet access from within OpenWrt

current hardware config

and network

I already mentioned that you do not have a valid IP on your WAN interface, so the Internet can't work.

Please post the contents of /etc/config/network of the OpenWrt machine to see your network config.


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd6f:c316:b5be::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
- /etc/config/network 1/22 4%

Oh yeah, there is no WAN. Did you boot the VM with just one NIC for the first time?

Anyway, you need to add a WAN interface to the config file. As an alternative, a factory reset should recreate the file with WAN.

x86 ext4 has factory reset option? could you please elaborate how to do that?