Openwrt Plusnet Router Main Issues

This is my final thread, so can I please get a solution and end this

I need to get tp-link T2U nano or tp-link T3U plus working with 200Mbps

the T2U is supported but is only running at 60Mbps
the T3U is realtek 8812bu chipset

if there is a driver would I be able to install it with opkg or the upload package button as I can not recomile openwrt

From your router:

ubus call system board
cat /etc/config/wireless (remove passwords and MAC addresses)

For adapters:

lsusb

If you have like ubuntu or fedora it helps to use ethtool -i wlan5 to determine auto-driver, but Ill derive that from hardware IDs anyway.

EDIT: correct button , will be kmod-domething and something-firmware for each particular adapter

{
        "kernel": "5.15.137",
        "hostname": "Plusnet-router",
        "system": "xRX200 rev 1.2",
        "model": "BT Home Hub 5A",
        "board_name": "bt,homehub-v5a",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.2",
                "revision": "r23630-842932a63d",
                "target": "lantiq/xrx200",
                "description": "OpenWrt 23.05.2 r23630-842932a63d"
        }
}
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
        option channel '48'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'
        option country 'GB'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:0e.0'
        option channel '10'
        option band '2g'
        option htmode 'HT40'
        option cell_density '0'
        option txpower '20'
        option country 'GB'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/1f400000.fpi/1e101000.usb/usb1/1-1/1-1:1.0'
        option channel '48'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'
        option country 'GB'
        option txpower '17'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid '###'
        option bssid '###'
        option encryption 'sae'
        option key '###'
        option skip_inactivity_poll '1'
        option disassoc_low_ack '0'
        option ifname 'STA'

config wifi-iface 'wifinet1'
        option device 'radio2'
        option mode 'ap'
        option ssid '###'
        option encryption 'sae-mixed'
        option key '###'
        option network 'lan'
        option short_preamble '0'
        option skip_inactivity_poll '1'
        option disassoc_low_ack '0'
        option ifname '5GHz'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option ssid '###'
        option encryption 'sae-mixed'
        option key ###'
        option network 'lan'
        option ifname '2.4GHz'

lsusb: not found

I am running openwrt and only openwrt
I have used the adapter with linux Raspberry Pi OS before with this driver

git clone https://github.com/morrownr/88x2bu-20210702.git

cd 88x2bu-20210702

sudo ./install-driver.sh

First you have 2 active radios on same channel, which is outright dangerous for amplifier circuits in both.

That is not Linux mainline driver, but something semi-proprietary from realtek.
Run lsusb from usbutils package to identify connected USB device.

radio2 is the T2U that only gets around 60Mbps

Bus 001 Device 002: ID 2357:0138 Realtek 802.11ac NIC
Bus 001 Device 001: ID 1d6b:0002 Linux 5.15.137 dwc2_hsotg DWC OTG Controller

Sadly only out-of-tree driver is available, like you installed on debian. Nothing in upstream kernel and consequentially in OpenWRT. You can try forcing rtl8xxxu driver BUT your failure may vary,,,,

I did try with the driver I listed above but it says gcc needs to be installed
I go to install it and the system crashes

Forget about gcc, device is plainly unusable on Linux except on few select realtek-supported distributions. Also mobile adapters are one-antenna 15dBm typically, which means 2-3x less coverage distance and abysmal speeds.

What i was asking - install kmod-rtl8xxxu
then
echo 2357 0138 > /sys/bus/usb/drivers/rtl8xxxu/new_id
(i might have missed some letter in path, use autocomplete)
then observe dmesg, if it says bad chip version or plainly crashes, sorry no luck there either.

echo 2357 0138 > /sys/bus/usb/drivers/rtl8xxxu/new_id
-ash: can't create /sys/bus/usb/drivers/rtl8xxxu/new_id: Permission denied

It likely depends on some kernel config option, i checked certainly not enabled on OpenWRT....

any idea about the T2U then that uses mediatek and is supported by openwrt, just gives me 60Mbps, I have seen 200Mbps on a windows PC, so why is it limited in openwrt

Because you overlap channel with 10x bigger antenna 1cm away?

You've said this many times already, and then started new threads. Why is this time different?

Why won't you listen to the advice that has been given in the other dozen+ threads?

2 Likes

now you answer me
Don't start again, I only had to make this one because the last one was closed
If you let me get a solution, I will not create any more threads for at least a few years

what is the point me having an account if you will not let my post anything

but that's STA for radio0 which is the built in
I have tried moving it further away with a USB extension cable, but it only made a small difference
the T2U is the mini version

Whenever big antenna transmits small antenna resets, your fight for justice will plainly end with you frying amplifiers in small antenna and problem will just fume away. I think this is dead end, you are not willing to change or improve anything.

I am trying, I don't know what to improve, that what I am trying to get from this

even 2 metres or 1.5 metres apart its the same
I don;t think any of the antennas are big really
there both in the PCB

the voltage on the USB adapter after the extension cable is 4.9 volts but that can't cause an issue.

I could try running it off its own supply with just the data and ground connected to the plusnet router, and the VCC and GND connected to a separate 5V source, but I don't think it will help

there are antenna points on the router PCB not being used so it can't be that big of an antenna

put 2 wifi radios on different channels? just like that?

I have and it makes zero difference to the speed