OpenWrt PI4b '' blocking state, disabled state''

trying to set up openWRT on my pi4. keep getting this issue.

im following this guide from NetworkChuck.. literally followed everything step by step.

not familiar with any of this at all but im learning and its so fun. just hit a discouraging brick wall. Thank you for any help you are able to provide. <3


i also can not ping or download packages. im going to ssh into it, and get the configs if someone needs more info.

The diabled, enabled, blocking and forwarded state things is kind of standard operating procedure in the log as of 21.02.

You will get that on any connection you remove and insert in a rj45 connector and you did restart the wireless so you did disconnect it and connected it again.

Seen this text on smart switches many years before openwrt got it so your wifi problem isn’t that text.
It is more likely a ordinary configuration error somewhere.

actually figured it out.. user error, still new to this. lol.

i did however, run into another issue. i inserted my mediatek 802.11 n WLAN wifi adapter. i ran - opkg update ( was successful ) then i ran

opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb kmod-usb-core kmod-usb-uhci kmod-usb-ohci kmod-usb2 usbutils openvpn-openssl luci-app-openvpn nano

i got this.. no such device.

Is it even possible to install kmod packages with opkg? I think you need to build a new firmware with the kmod packages?

Of course. There are lots of Kmods that you can install. They are kernel modules, not different kernel versions. For example, kmod-wireguard is a module that is installed to enable the use of the wireguard protocol.

so ive gotten alot further. i can access GUI, but i cant see the network like if i try to connect from my phone, i dont see the network. unplugged from eth i can ping google, but i cant see the network from my phone. which i think its because for some reason this isnt working. its probably something im doing.

its also not showing up when i '' vi wireless " before i seen the interface config, but now i dont. i tried to add it from coping the tutorial ive been watching but im getting errors.

Have you tried to have a non space ssid?
And instead of the pictures with config…