OpenWrt on Orange PI PC cannot ping Arduino

Canont undestard... from my orange Pi PC with OpenWRT 22.03 I cannot ping an Arduino board equipped with ethernet shield.. But the Arduino board works..from my PC I can ping it.
Is there some library missing or..?

Maybe give more details. Is is impossible to diagnose a problem with no description of your network configuration/topology and how you are trying to connect between devices.

Architecture is just a star (I'm doing some test). Like this (very easy)
Net

PC can ping Arduino ; OpenWRT (Orange Pi PC) Can't

Is the OpenWrt system acting as the dhcp server for the network? Is there another router in the network? Is this network internet connected? If so, is that using the openwrt device or some other router? And can all devices reach the internet?

And what are the ip addresses for each device?

they're on same network:
Untitled Diagram.drawio

PC can ping Arduino
OpenWRT cannot ping Arduino

is it possbile to run Wireshark on OpenWRT?

No, but tcpdump/ tcpdump-mini.

Try swapping cables and ports between the pc and openwrt to rule out a bad physical connection.

Let’s also see your configuration.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

I already try to swap cables, no changing
This is the printout of cat /...

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd65:9b2e:d641::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        option ipv6 '0'
        option bridge_empty '1'
        option acceptlocal '1'
        list ports 'eth0'
        list ports 'eth1'
        option promisc '1'
        option vlan_filtering '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        list dns '8.8.8.8'
        list dns '8.8.4.4'
        option ipaddr '192.168.1.3'
        option gateway '192.168.1.254'
        option broadcast '192.168.1.254'

config device
        option name 'eth0'
        option ipv6 '0'

config device
        option name 'eth1'
        option ipv6 '0'

NO wireless is configured

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'
        option dynamicdhcp '0'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'
        list device 'br-lan'

config include
        option path '/etc/firewall.user'

config redirect
        option target 'DNAT'
        option name 'M590_ip150'
        option src 'lan'
        option src_dport '502'
        option dest 'lan'
        option dest_ip '172.16.11.150'
        list proto 'tcp'
        option dest_port '530'
        option src_dip '172.16.11.150'

config redirect
        option target 'DNAT'
        option name 'M590_ip152'
        option src 'lan'
        option src_dip '172.16.11.152'
        option src_dport '502'
        option dest 'lan'
        option dest_ip '172.16.11.152'
        option dest_port '531'
        list proto 'tcp'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip152'
        option src 'lan'
        option src_dport '502'
        option dest_ip '172.16.11.154'
        option dest_port '532'
        option src_dip '172.16.11.154'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip156'
        option src 'lan'
        option src_dip '172.16.11.156'
        option src_dport '502'
        option dest_ip '172.16.11.156'
        option dest_port '533'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip160'
        option src 'lan'
        option src_dip '172.16.11.160'
        option src_dport '502'
        option dest_ip '172.16.11.160'
        option dest_port '534'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip162'
        option src 'lan'
        option src_dport '502'
        option dest_ip '172.16.11.162'
        option dest_port '535'
        option src_dip '172.16.11.162'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip164'
        option src 'lan'
        option src_dip '172.16.11.164'
        option src_dport '502'
        option dest_port '536'
        option dest_ip '172.16.11.164'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip166'
        option src 'lan'
        option src_dip '172.16.11.166'
        option src_dport '502'
        option dest_ip '172.16.11.166'
        option dest_port '537'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option src 'lan'
        option src_dport '502'
        option dest_ip '172.16.11.11'
        option dest_port '510'
        option name 'M590_ip11'
        option src_dip '172.16.11.11'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip30'
        option src 'lan'
        option src_dip '172.16.11.30'
        option src_dport '502'
        option dest_ip '172.16.11.30'
        option dest_port '511'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip50'
        option src 'lan'
        option src_dip '172.16.11.50'
        option src_dport '502'
        option dest_ip '172.16.11.50'
        option dest_port '512'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M290_ip51'
        option src 'lan'
        option src_dip '172.16.11.51'
        option src_dport '502'
        option dest_ip '172.16.11.51'
        option dest_port '513'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip60'
        option src 'lan'
        option src_dip '172.16.11.60'
        option src_dport '502'
        option dest_ip '172.16.11.60'
        option dest_port '514'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip61'
        option src 'lan'
        option src_dip '172.16.11.61'
        option src_dport '502'
        option dest_ip '172.16.11.61'
        option dest_port '515'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip70'
        option src 'lan'
        option src_dip '172.16.11.70'
        option src_dport '502'
        option dest_ip '172.16.11.70'
        option dest_port '516'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip71'
        option src 'lan'
        option src_dip '172.16.11.71'
        option src_dport '502'
        option dest_ip '172.16.11.71'
        option dest_port '517'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip80'
        option src 'lan'
        option src_dport '502'
        option dest_ip '172.16.11.80'
        option dest_port '518'
        option src_dip '172.16.11.80'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip81'
        option src 'lan'
        option src_dip '172.16.11.81'
        option src_dport '502'
        option dest_port '519'
        option dest_ip '172.16.11.81'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M590_ip100'
        option src 'lan'
        option src_dport '502'
        option dest_ip '172.16.11.100'
        option dest_port '541'
        option src_dip '172.16.11.100'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M290_ip12'
        option src 'lan'
        option src_dport '502'
        option dest_ip '192.168.2.12'
        option dest_port '503'
        option src_dip '192.168.2.12'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M290_ip30'
        option src 'lan'
        option src_dip '192.168.2.30'
        option src_dport '502'
        option dest_ip '192.168.2.30'
        option dest_port '504'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M290_ip31'
        option src 'lan'
        option src_dip '192.168.2.31'
        option src_dport '502'
        option dest_ip '192.168.2.31'
        option dest_port '505'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M290_ip32'
        option src 'lan'
        option src_dip '192.168.2.32'
        option src_dport '502'
        option dest_ip '192.168.2.32'
        option dest_port '506'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M209_ip55'
        option src 'lan'
        option src_dip '192.168.2.55'
        option src_dport '502'
        option dest_ip '192.168.2.55'
        option dest_port '507'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M209_ip65'
        option src 'lan'
        option src_dip '192.168.2.65'
        option src_dport '502'
        option dest_ip '192.168.2.65'
        option dest_port '508'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M209_ip80'
        option src 'lan'
        option src_dip '192.168.2.80'
        option src_dport '502'
        option dest_ip '192.168.2.80'
        option dest_port '509'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M290_ip21'
        option src 'lan'
        option src_dip '192.168.2.21'
        option src_dport '502'
        option dest_ip '192.168.2.21'
        option dest_port '510'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M290_ip20'
        option src 'lan'
        option src_dip '192.168.2.20'
        option src_dport '502'
        option dest_port '518'
        option dest_ip '192.168.2.20'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option src 'lan'
        option src_dip '192.168.2.22'
        option src_dport '502'
        option dest_ip '192.168.2.22'
        option dest_port '511'
        option name 'M290_ip22'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M290_ip100'
        option src 'lan'
        option src_dip '192.168.2.100'
        option src_dport '502'
        option dest_ip '192.168.2.100'
        option dest_port '513'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M290_ip101'
        option src 'lan'
        option src_dip '192.168.2.101'
        option src_dport '502'
        option dest_ip '192.168.2.101'
        option dest_port '514'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'M290_ip10'
        option src 'lan'
        option src_dip '192.168.2.10'
        option src_dport '502'
        option dest_ip '192.168.2.10'
        option dest_port '515'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option src 'lan'
        option src_dip '192.168.2.15'
        option src_dport '502'
        option dest_ip '192.168.2.15'
        option dest_port '516'
        option name 'M290_ip15'

this is the ping from PC. I can only note the TTL is 128 in stand of 64

Remove this line.

And remove this.

I cannot remove

list device 'br-lan'

I need it for fireweall rules (actually I'm using port forwarding)

You already have the network ‘lan’ included in that firewall zone. You do not need (and should not have) the device specified there.

If I disable the bridge, I can ping the Arduino... Cannot understand why.
But with bridge unabled I can ping device with IP similar to Arduino (same network) (ex 192.168.1.10 )..