Openwrt on MiniPC N5105 4xIntel I226V - No network

Hi,

I have just tried to install Openwrt today's development snapshot (https://downloads.openwrt.org/snapshots/targets/x86/64/openwrt-x86-64-generic-ext4-combined-efi.img.gz) on a Celeron N5105 Minipc with 4xIntel I226-V 2.5 Gigabit ethernet, yet the network does not come up. As far I understood it should be supported in module kmod-igc (the module is installed), I am pasting dmesg output, do you have any idea why it doesn't work ?

Thanks anyone for their help.

Federico

DMesg output https://pastebin.com/MBwhgRmc

[ 7.115506] igc 0000:02:00.0: PCIe PTM not supported by PCIe bus/controller
It may be a BIOS issue. Try to enable PTM.

i have the same device but fortunately everything works as it should.

You are on a multi NIC system, not on a layer3-switch-shelf-router. The network likely does come up, but probably not matching your expectation of the default situation.

Keep in mind that out of the box there is only a single LAN and a single WAN port in use on a multi NIC system. And OpenWRT chooses these ports on its own.

So only 1 of the 4 ports will work out of the box as LAN.
Did you test all 4 NIC ports with your client?

2 Likes

Is it an option in BIOS ? What is PTM ?

I include also output of ifconfig -a and lspci (it was done on an ubuntu live usb since I was unable to install pciutils package without network)

ifconfig https://pastebin.com/N6rMFiXz (it should get an ip 172.17.1.xx through dhcp)
lspci https://pastebin.com/1w6WfGCF

It has 4 ethernet ports how can I configure a port as wan ?

Edit the /etc/config/network file as shown. That's how it works for me.

1 Like

Something like "precision time management" ? I don't have recent hardware to check.

I would recommend that you install 22.03.2 instead of the current snapshot. You will have Luci for easy configuration.
Default setup is : eth0 for LAN and eth1 for WAN.
With Luci (network, interfaces), you can easily customize your ports. Suggestion eth3 for WAN, and eth0 eth1 eth2 for LAN.

I have such a tiny device as main router. Once set up, it works like a charm and it's very efficient (from a bandwith point of view).

1 Like

Thank you very much, I have mostly configured openwrt from web interface. I'll try in the next days and I'll let you know.

1 Like

OpenWRT stable release has kernel 5.4
kmod-ige (Intel 1225-V) only works with kernel 5.1 (OpenWRT 22 Snapshot)

I first installed the 22.03.0 rc6 version with the builder as well as kmod-igc and luci.

I have the same device, eth1 is the wan eth0,2,3 are the lan!

latest stable 22.03.x runs on kernel 5.10

You probably mean 5.10

There are few differences between 22.03.2 and 22.03.snapshot, whereas master snapshot runs on kernel 5.15.

You can configure this the way you like.

1 Like

Thank you all very much it works perfectly...I have taken it mainly as a VPN gateway, tried on Windows 11 it worked but speed was limited to 60 Mbit/s on a 2.5gbit/s line, I have seen videos on internet of these N5105 minipcs reaching over 700 mbit/s in openvpn and over 900 Mbit/s in wireguard, I'll let you know as soon as I have set it up.

I use NordVPN over OpenVPN on this and they get 900Mbit maybe it could handle more but my carrier is only 1Gbit.

Glad you succeeded. Installing on an x64 should be rather easy.
Now that it works, you may want to try a snapshot because it runs kernel 5.15. Use the firmware selector to create an image, and don't forget to customize by including luci.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.