OpenWRT on Mikrotik RBwAPG-5HacD2HnD (wAP ac) with RouterOS 6.46 preinstalled

Hi all,

due to a recommendation I got myself a Mikrotik RBwAPG-5HacD2HnD (wAP ac) and wanted to install OpenWRT. I tried to boot OpenWRT via netboot/TFTP first, but it always boots RouterOS.

I guess this is due to the fact that it comes preinstalled with RouterOS 6.46, which the "Mikrotik common" page states is not compatible.

Unfortunately I found no instructions on how to downgrade or where to get an older RouterOS release.

  1. Has anyone installed OpenWRT on Mikrotik boards lately? Does that 6.46 version contraint still apply? Or should it work now?

  2. Does anyone have a good link or howto on how to downgrade the RouterOS on this device?

Thanks in advance.

Kind Regards

Get a try with netinstall from mikrotik,
And check this 1st, to downgrade, it apply to all RB.

I have a few of these devices, but it's been a while since I migrated to OpenWRT. As @nomadeh already pointed out, you'll still need to downgrade. If you run into any issues with downgrading or finding older firmware, I have version 6.44.6 on hand.

Thanks for the answer. But this also says:

In fact you can downgrade RB units any firmware down to Factory Firmware

In my case the factory firmware seems to be 6.46...

Could you send that file (via DM?) or put it online somewhere (in case this is safe to do)?

all you need is here:

Just select ARM ( 32bit ) firmware
But... as I wrote, downgrade only, down to factory version.

1 Like

Sorry, I forgot to reply. I found the archive of all the older versions.

But I guess I am out of luck, as my factory version is already 6.49:

         uptime: 11m12s
         version: 6.49.7 (stable)
         build-time: Oct/11/2022 14:37:24
         factory-software: 6.49

If I read the docs properly, I could only downgrade to 6.49 which is too new for OpenWRT, right?

Kind Regards,

Yeap, correct, oldest firmware for your device is 6.49. I never see reports about downgrade lower than factory firmware on a RB device.
Save/export you licence RB key first , and make a try with netinstall an a lower firm than 6.49 on your device... I never did that, and don't know what could be the results.

Just use bootp OR dhcp. I user tftpd on another OpenWRT AP to transfer files.
I did that with several MTIK AP of this type.
Just do not upgrade to RouterOS V7.x!

Thanks, will try.

Do you have a link at hand for which files I need for bootp? Is the enough? Or do I need other files?


6.45 netinstall should be fine. Usually I use 6.47 and 6.49 netinstall, even uploading 7.x firmware

My question was more regarding which files I need to provide via TFTP. I would test more versions until I find one that works (or give up...).


For you device, ARM, any file ( firmware ) named: routeros-arm-X.XX.npk

1 Like

Hmmm, I can see the DHCP requests and how the AP fetches the file from the DHCP server. But I cannot even downgrade to 6.49 (without a third digit), I always end up at 6.49.7.

I tried 6.45.7, 6.45 and 6.49 without success...

Huh, funny. After reaching out in the Developers-section I tried to netboot openWRT once more. And it worked?!?!

In other words: I have OpenWRT running via Netinstall on a MikroTik wAP that came with 6.49.7 preinstalled...

Aaaaand I could successfully install a snapshot OpenWRT which comes up after powering off the device. So seems like the install was successful!


Thanks everyone for your help!

Just for info

info on chassis says D2HNd (wap ac), but i have to (use) build for:

Model MikroTik hAP ac2
Target ipq40xx/mikrotik

otherwise sysupgrade won't work.

Hello guys. I can confirm that "MikroTik hAP ac2" shipped with RouterOS 6.49.11 is compatible with current OpenWrt 23.05.0