OpenWrt on EAP245v3 shows bad file

Hello,
When I try to install OpenWrt from newest stock 5.0.3 (EAP245(EU)_V3_5.0.3_20210604) then after choosing file location and pressing Update button, system shows info: bad file

I restored to Factory settings before.

ps: I use this file: http://downloads.openwrt.org/snapshots/targets/ath79/generic/openwrt-ath79-generic-tplink_eap245-v3-squashfs-factory.bin

Pls help

Did you try shortening the file name? I think something about this is mentioned in the device page.

Still a interesting topic! I was planning this operation my self this weekend and I have the same firmware in my AP also.

Yes I made shorter name and still doesn't work.

pt., 24 wrz 2021, 23:45 użytkownik Daniel via OpenWrt Forum <mail@forum.openwrt.org> napisał:

https://www.tp-link.com/se/support/download/eap245/v3/#Firmware

Where have you found this 5.0.3 firmware? TP-Link have now EAP245(EU)_V3_5.0.2_Build 20210303

1 Like

Try the installation instructions in the wiki

1 Like

I tried via web only. Other metods are too hard for me.

sob., 25 wrz 2021, 08:23 użytkownik Marko Paasila via OpenWrt Forum <mail@forum.openwrt.org> napisał:

If ssh is to hard for you, then using OpenWRT will be a very steep learning curve.

What method did you use for your replies when you got this text in the bottom? I have been around here a long time and I have never seen this before?

Please follow the install instructions as listed in the commit message. It's impossible to install OpenWrt using only the web GUI, but it really isn't that hard:

  • ssh into target device and run cliclientd stopcs
  • upload factory image via web interface

They are replying via email, so this is just the typical header to a quoted message.

1 Like

Pls give me some advice or mybe link to step by step for Windows. I "know" DOS comands, So I Will try with ssh.

sob., 25 wrz 2021, 10:28 użytkownik Daniel via OpenWrt Forum <mail@forum.openwrt.org> napisał:

If you are using Windows 10, an SSH client is included with the OS:

1 Like

Thank you. What this command: cliclientd stopcs does?

TP-Link adds a cryptographic signature to their firmware, and OpenWrt doesn't have the key required to generate these. Normally, the firmware will find that the OpenWrt factory image is not "trusted", and will refuse installing it. By issuing the cliclientd stopcs command, we're telling the firmware that it can trust any image we provide, which allows us to install OpenWrt.

1 Like

Thank you.
I used putyy and Type command cliclientd stopcs.
Now the img is uploaded via web.

After tat I type IP of router in Webbrowser and nothing happens. How can go to my router now?

IP is 169.254.194.91

During uploading EAP was connected to main router via LAN.

The device uses a static address of 192.168.1.1 after a fresh install. The wiki has plenty of info, see for example https://openwrt.org/docs/guide-quick-start/walkthrough_login

Yes you have right.

I try 192.168.1.1 via putty and works. Doesn't work via Web.

Pis help me run web interface

The Development builds / snapshots do not include LuCi.
You will need to install LuCi manually.

If you want a release with LuCi already included,
Use the Stable Release builds

From a Windows Command prompt -

ipconfig /release

ipconfig /renew

Depending if you installed the 21.2.0 or the master snapshot (which the device page still links to?), you only have luci on 21.2.0, for the snapshot you need to first download luci with the use of ssh.

But then you need to connect the access point directly to a computer since it works like a dhcp server/router after the install (which is kind of super awkward and very strange basic setup for a PoE access point!) so you need to find the old PoE converter and plug it to the computer. Then your computer will get a IP address from the AP and you log in to 192.168.1.1. Then you change the LAN IP setup from Static address to DHCP client. (Note that this will loose connection to the router and you need to force the setup) Then you can connect it as an actual access point to the switch or router and log in to it as you usually do through the router when you have an access point.

Longer than that I havenÔÇÖt got yet. But since we are already here we can take the next question right away. The eap245 gets delivered in OWRT with both swconf and DSA switch setup possibilities, which one are we supposed to use and are both working?

This target doesn't use DSA at the moment, and is still on swconfig. I think they're currently looking at using the upstream qca8k driver on the ath79, which would use DSA. But that's only relevant for master (i.e. snapshot builds), 21.02.x will stay on swconfig.

1 Like

Like others have noted, it sounds like you've installed a snapshot image, instead of the 21.02 release.

You will need to download the 21.02.0 sysupgrade image on the device, and install it using the sysupgrade utility.