OpenWrt on 2nd router, lost control over 1st

Hi there, I'm a brand new user,

I own a Mi Router 3G from Xiaomi (chinese interface nightmare), was having a very hard time port-forwarding for a few devices on my LAN so I decided to try OpenWrt... Had a lot of trouble setting a different IP on my LAN but I finally managed to do it, changed from to 192.168.X.1, had to do it because my router is actually connected to a 1st ISP router (in another building) connected through CAT6 eternet cable.

I used to be able to connect to the 1st router by just typing the and log in as admin to establish a static IP and DMZ for my router when I was running the stock firmware on the Mi Router 3G...

Now I can't do that anymore, even if I changed LAN IP for my network, it still tries to connect to OpenWrt when I look for the ISP router IP I think... And it says NGINX 404 not found.

Is there anyone willing to help me understand what I'm doing wrong, I tried to look to all possible documentation on OpenWrt website, I also tried to revert to the stock firmware a few dozen times with no success, being stuck with OpenWrt I would like to understand how to fix this problem.

I really need to be able to manage the ISP router through my router, of course I can connect to it by plugging in the ethernet cable, but I must set the static IP for my router when it's plugged in, I have a few devices that I want connected to the WAN through port forwarding like a web server.

I used to just DMZ my router with firewall set up, I would like to do the same now, any suggestion on security features that I should implement on the basic install?

FYI I only changed my LAN IP as previously mentioned, set to static ip mode, nothing else after the 2 or 3 resets I made on my configurations... WAN points to



Did you install NGINX on the router?

If not, are you sure you don't have an IP conflict?


No I just followed the install instructions provided, downloaded a couple OpenWrt .bin files and flashed them... I then did a few "upgrades" in the dedicated web interface section, but after that I did a couple resets to the router so I don't know if they're still in place.

I will get back to that router tomorrow, I have Nginx on a webserver that is connected to that router through wifi, but wifi was turned off while this happened.

For a brief moment I see the loading page of OpenWrt when I type then the Nginx error. If I force or something like that I can access the login interface of the main router, but when I press on login again, OpenWrt loading page and Nginx error.

I just tried to set the IP as it was before on the stock firmware when I could reach the main ISP router, 192.168.x.1 with main router being Someone on Facebook suggested I should use another IP (closer to the 1st router) to fix this problem, I don't understand then how the stock firmware managed to let me peek in the main router admin interface...

Clear your web browser cache.