OpenWrt not detecting internet correctly

I am having a weird problem that just started a few days ago. Normally I am able to connect my OpenWRT routers to my Comcast cable internet with no issues. It is normally plug and play except for whatever packages I want to add. However, now for some reason I am only able to get an internet connection on my desktop computer. No other devices are connecting. On the desktop I am limited to pretty much just Google searches. Anytime I try to load a page the page will not be displayed.

Hard to know why this would happen without more context. Did you change anything (install a package, change a configuration item, etc)? Have you tested pinging an IP address from the affected systems (for example, and then a domain name ( That might provide some insight.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

It is doing it right after a fresh install. Normally after a fresh install my wired devices have a connection. I just need to configure wireless from there. I have tried multiple OpenWRT routers and I can no longer get any to work anymore.

What is upstream of your OpenWrt router? Is the device that connects to Comcast a modem only or is it a modem + router?

If modem only: You need to restart your modem (possibly a few times) in order to clear the 'learned' MAC address of the previous router. The modem will only issue an IP to a single device (bound by the MAC) until the modem is rebooted to allow it to learn a new MAC.

If modem + router: you may have an address conflict -- you need to make sure that you don't have the same subnet on the WAN and LAN of your (OpenWrt) router. If your upstream device is operating as a router on the network, you must change one or the other to be a different subnet (for example, or any RFC1918 address). Or, set the modem+router device to be a modem only (bridge/pass-through mode).

1 Like

Thanks for your help. I believe this will fix the problem as after reflashing back to stock I set the Netgear router to default MAC. For some reason it was set to clone PC. Once I rebooted the modem and router it worked. I am going to reflash OpenWRT and try again.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.