OpenWrt not accessible after flashing custom firmware

Hey there,

I have run into serious troubles with my custom OpenWRT image:

I have been using the TP Link WA901nd v2 AccessPoint with OpenWRT 18 so far without problems. Today I have built a custom image using the Image Builder (ar71xxx tiny) and I disabled some "unnecessary" packages (imo), including the dropbear-package.

When flashing the new firmware, it never completed and the system is not accessible anymore. That means, I cannot connect to the AP via SSH, Telnet or Web.

I also resetted the AP and the IP-Adress is now Furthermore, I have run an NMAP scan and there is only the port 53/tcp open (which is DHCP). Interestingly, the AP is giving DHCP leases.

Moreover, entering failsafe mode does also not work - I have also no idea if I entered it correctly ... Pressing RESET button after power on until System-LED flashed quickly?

Lastly, I also tried the TFTP recovery procedure which is common with TP Link devices - but the AP isn't requesting any images by TFTP (IP-Adress of Server:

So, in conclusion:
*) flashed custom image with less packages, not including dropbear
*) AP didnt boot anymore
*) No access via SSH, Telnet or Web
*) Can't enter failsafe mode

Right now I'm thinking about buying a new AP ....

Or does anyone of you know what I could do to rescue my AP?

Thanks in advance!

FYI there is no telnet daemon anymore. Most likely you removed something else and broke Luci too.
Also you'll need a TTL to USB cable.

Instruction how NOT to do.

thanks for nothing

thank you! but actually its not worth investigating more time in this procuredure, since i dont have the hardware ...

You could get one for a few bucks, or if you have a Raspberry Pi in hand you could do with it. But then again, as you say, it could be spending much time on a router that's not very suitable for OpenWrt due to limited storage and RAM, so you could just donate it to someone who can fix it and make some other use of it.

Well I own a Raspberry Pi 1 Model B. If you could give me any advide, tutorial or guide how to connect to the serial port, I would definately try it!


Well, I haven't tried it myself, although I need to do it sometime soon. If you search the forum or the internet you will find something. But basically you will connect the router to the Pi header pretty much the same way you would connect the router to the TTYL adapter as per your device page for serial connection. And then you will do the flashing from the Pi itself.

In brief, you would need to do the following:

  1. Have the Raspberry Pi running a suitable OS (e.g. Raspbian).
  2. Find the RX, TX and GND pins on your Raspberry Pi (e.g. form the manufacturer documentation).
  3. Refer to your device page on OpenWrt Wiki to find info about serial connection.
  4. Do the connection and the serial flashing as per the Wiki .Note that you connect RX to TX and TX to RX.

Is that the talk to you later adapter? :smiley:
Welcome back mate!


Well, it does talk to you, and it usually takes some time until it talks... So, that works too.


Hey again.

I tried some tutorials to get the serial connection working, but no success at all.

My serial terminal "minicom" shows nothing when powering on the Linksys AP. I could verify that is is working if i connect the PIN14 and PIN15 directly toghether, seeing the output of what i typed.

But if I connect the wires according to plenty tutorials, nothing happens! Look at the screenshots, everything is correct - isn't it?

(Sure, I disabled the shell output on serial device by using raspi-config: No + Yes)

Really no plan anymore ...

According to this, it looks like you have the TX and RX the other way around on the router.

Also did you note typing tpl to get to boot menu? Timing can be tricky, so you may need to try a few times.

1 Like

You shifted one pin to the right. The left, unsoldered pin is TX, that's why you don't see any output.
Take a look at v3 pinout.

1 Like

@danijeltudek are you sure? you know that i am using V2 not V3! thats maybe a different pin out.

@Hegabo i changed RX and TX cables some times, but it doesnt matter which one to which one, no output at all (it should be RX <-> TX i think, so if you mean the RPi pins, it should be correct)

This is the diagram on the openwrt website.

Yes, my bad, but still, it's shifted. On both v2 and v3, left pin is RX or TX. Check the image that you posted, you can see that RX line goes to the pin that's marked on the PCB.


You guys were right. wrong pinout -> see image below for correcot one, the TX pin is surrounded by a white rectangular.

Now, the boot process shows up in the terminal:

U-Boot 1.1.4 (Feb 24 2012 - 16:48:46)

AP81 (ar7100) U-boot
32 MB
id read 0x100000ff
flash size 4MB, sector count = 64
Flash: 4 MB
Using default environment

In: serial
Out: serial
Err: serial
Net: ag7100_enet_initialize...
No valid address in Flash. Using fixed address
bsingle_phy = 0
eth0: 00:03:7f:09:0b:ad
eth0 up
Autobooting in 1 seconds## Booting image at bf020000 ...
Uncompressing Kernel Image ... OK

Starting kernel ...

OpenWrt kernel loader for AR7XXX/AR9XXX
Copyright (C) 2011 Gabor Juhos <>
Looking for OpenWrt image... found at 0xbf022000
Decompressing kernel... done!
Starting kernel at 80060000...

[    0.000000] Linux version 4.9.198 (buildbot@a6cb27977ad2) (gcc version 7.3.09
[    0.000000] bootconsole [early0] enabled

But when I press CTRL+C or enter "tpl", nothing happens, it just boots!

@danijeltudek was right. I was half-wrong (or half-right)

Timing is tricky, and you need to be fast in typing. Keep trying (and double-check the router's Rx connection).

Enter 'tpl' exactly when the "Autobooting in 1 seconds" comes up. Copy and paste it into your terminal screen.

What happens if you let the kernel boot all the way? Does it stop after the two lines you posted?

pressing it immediately when "autobooting" appears works!

but how do i transfer the openwrt image via YMODEM? cant get that shit working ...

1 Like