OpenWrt installation on Nighthawk X6S AC4000 R8000P

Brothers, help me) How to install OpenWRT on this model of the R8000P router? TFTP is not working (Reset+Power), SSH is not working .... How to load .bin into the router's memory? The web interface only accepts the .chk file extension

When in doubt, check the commit message for instructions:

Borromini thank u very much for ur reply. I can use search.... The only way is serial console access???

1 Like

That commit comment is now quite old, and doesn't reflect the fact that there's now a stable release build for said Router. I am looking for the same because I have an R7900P and they're identical, so I need a method. I've tried TFTP but it fails, and I've tried NMRPFlash with the following command:
nmrpflash.exe -v -i net13 -a -A -f openwrt-22.03.0-bcm4908-generic-netgear_r8000p-squashfs.bin
Which does make it work, it does upload the file to the Router and returns an "OK" message, but then gets stuck on the "Waiting for remote to respond.". After that, the Router boots up but it boots into Stock Firmware.

Try my method I mentioned, it might work for you on your R8000P, as I have an R7900P and it fails, but your R8000P might work with the software and command I mentioned. Let me know how it works.

(Make sure to set your Ethernet Adapter IP to, Mask to and Router Gateway to

Okay, now I'll try this method :slightly_smiling_face:

I'm not sure why you think it's 'old' (does it really matter when support was added?) and why it should reflect the fact there's a stable build now. By definition there never is a stable build when support gets added, since support only gets merged into master, and sometimes backported to stable releases from there. Never the other way around.

From a certain point on, OpenWrt developers agreed that commits adding device support should contain instructions on how to flash the device. Which is the case here, and which is why I linked to it, and why the device page or technical data page always links to it.

You're thread hijacking now, but it never hurts to try older images. Sometimes things break.

It's not thread hijacking when it's the same device, christ... And an older image was up until 22.03 just a snapshot, so I have a hard time believing that it'll work any better. I really don't think the method I've found & tried actually really works, it just uploads the file but it doesn't get successfully flashed.

Hooking up serial could result in output which could help in detecting the root cause of this issue.

That could very well be, and if someone who has serial access to the Router wants to try my method with NMRPFlash and see what causes it to fail, maybe we could actually get a working flash going. I however do not have a serial cable for this Router and neither the expertise to make one and connect it, so it'll have to be someone else with an R8000P/R7900P.

Would buying a USB to TTL cable suffice for me to get serial access?

nmrpflash -L
net18 d2:f5:08:b6:20:09 (Ethernet 4)
net4 04:92:26:d9:4a:b7 (Ethernet)
nmrpflash.exe -v -i net4 -a -A -f openwrt-22.03.0.bin
Waiting for Ethernet connection (Ctrl-C to skip).
Adding to interface net4.
Advertising NMRP server on net4 ... \pcap_sendpacket: send error: PacketSendPacket failed: An I/O operation failed because the network media is disabled or the wireless access point is out of range (2150891551)

Yes you made the same mistake as I. Turn it off after full boot, run command, turn it on.

Do u have discord ?) Voice

I do everything as you said, turn off the router, enter the command "nmrpflash.exe -v -i net4 -a -A -f openwrt-22.03.0.bin" , get the warning "Waiting for Ethernet connection (Ctrl-C to skip)", turn on the router and get the error pcap_sendpacket: send error: PacketSendPacket failed

Dude I don't do Discord for this, if it doesn't work for you then it doesn't. I would recommend you to disconnect all other adapters or disable them as well.

Decided to order a PL2303HX after all and give serial console a try. Any quick guides/pointers for when I have serial console access on how I can obtain said logs (and also to push the OpenWRT .bin file)?

I disconnected all cables, only the router and the computer are connected via LAN

I've taken my Router apart and found that it has the 4x Serial Port pins, which is awesome. My USB to TTL hasn't arrived yet, but once it does I need to figure out which of the plugs is GND, Tx and Rx. Anyone able to give me pointers on how I can figure out which of those is which?


1 Like