Openwrt installation on mini pc does not boot

I wanted to tell you that I am trying to install openwrt on a mini pc and I have followed this tutorial:

And all the steps came out correctly but it does not start.

I checked the disk and all the partitions were made correctly, I don't know what the error could have been.

I have an intel n100 this equipment to be more exact:,scm-url:1007.40050.281175.0,pvid:8f5673a5-4c25-44e5-ba8c-345d66052edf,tpp_buckets:668%232846%238107%231934&pdp_npi=3%40dis!EUR!257.95!144.45!!!!!%40211b615316899643243234653e4ac3!12000033748352263!rec!ES!136037559

I have to modify something in the bios, someone who has it can enlighten me.
I'm a bit desperate.

Refer to the official OpenWrt guide on the topic... follow the directions exactly, then report on any issues you encounter:

1 Like

ok now I comment

It's here:

linked in my post.

1 Like

I have tried to boot with a bootable usb and nothing at all does not boot as it appears in the instructions

That's going to be down to the boot order configured in the computer's UEFI/BIOS.

You will have to find out how to change the boot order, or how to interrupt the boot sequence so that you can force it to boot from the USB stick instead of the internal storage.

If you have - or can search for - some documentation for the computer, it may tell you which function key(s) to press to get into the system setup, or interrupt the boot sequence.

If you don't have - or can't search for - some documentation for the computer, then it's going to be a case of trial-and-error; keep trying different function keys while starting the computer until you get a response.

It doesn't even detect it, it's as if nothing was installed. I think it has something to do with the bios of my mini pc, but I don't know.

Highly likely. If you know the USB stick is good - because you've tested it in another computer - then you can be reasonably confident that something about the mini PC is preventing you from booting from the USB stick.

What evidence have you observed to support this hypothesis? Is the USB stick undetected or is it being ignored ?

which image did you use ?
it should be the combined efi one ... squashfs or ext4 doesn't make any differance, at this point.

Instead I have been able to run the finnix with a usb memory This is the link of the image that I use

well, that would be wrong one, unless you change your bios settings to legacy mode

also, are you sure it's not booting, but without any video output ?

If I change it to legacy mode I have to reset the bios because it doesn't boot and if I put it in uefi and legacy mode it gets stuck booting
100% sure it won't boot

define "stuck".

efi image shouldn't be used with legacy mode, or vice versa.

it does not start in any way except with an advanced configuration

you write in riddles, how about some useful info ...

1 Like

And by "useful info" I expect that @frollic probably means something along the lines of "show, don't tell". Something like, for instance, this:

I don't have an N100, but I do have an N95. I suspect the UEFI is likely to be very similar to yours. It might not be, but I would be very surprised if these no-frills, cheap, Chinese no-name manufacturers have any interest in wasting valuable time ginning up a custom UEFI; paying the programmers would eat into their pile 'em high, sell 'em cheap profits.

This is what mine looks like:

As you can see, the USB stick (GPT, not MBR) is both detected and shown as a bootable device in the UEFI.

The above should indicate the sort of information which you might choose to provide and which might help your audience to help you.

All that said, this is not a PC support forum, but many of the forum members may still have relevant knowledge which might help. If you get lucky and someone else on this forum happens to have the same device as you, then you might get an exact response telling you precisely what to do to get it to work.

But be prepared for guesswork and trial-and-error, both on your part and on ours.


Given the (recent-) age of this device, just give the generic-squashfs-combined-efi.img.gz image a try (as your system is most likely configured for UEFI; secure-boot must be disabled).

1 Like

Solved and installed with efi mode and it has started. Now another problem has arisen that I have already commented on in another thread because it may have little to do with this