OpenWrt installation on Mi Router AC2100


Can someone please help me out?

I tried installing OpenWrt to my (cylinder shaped) Mi Router AC2100 using the easy method on this guide.

I first thought that the sentence ”If all has gone well, you should be rebooting into OpenWrt.” would mean that I could simply log in via a browser and start using OpenWrt at that point, but apparently I have to do the ”flash layout” part too, and that is getting way over my head without a simple step-by-step guide.

I guess I have done everything right (the second time after restoring stock firmware using an old virtual win 7 machine and sketchy Xiaomi restore tool) as I can now SSH into OpenWrt?
However I’m unable to access any login page at (and after changing the address via SSH using some tips on these forums)

Apparently I should fill in something somewhere on some table and then upload what and where and how?? to make this work? Sorry, getting a bit tired too after no sleep at all.

I was able to find the following (apparently relevant) info on my AC2100, but the part about little or big endian hex values on flash discovery page just got me really confused..

root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00080000 00020000 "Bootloader"
mtd1: 00040000 00020000 "Config"
mtd2: 00040000 00020000 "Bdata"
mtd3: 00040000 00020000 "factory"
mtd4: 00040000 00020000 "crash"
mtd5: 00040000 00020000 "crash_syslog"
mtd6: 00040000 00020000 "reserved0"
mtd7: 00400000 00020000 "kernel_stock"
mtd8: 00400000 00020000 "kernel"
mtd9: 07580000 00020000 "ubi"

[    0.683573] Creating 10 MTD partitions on "mt7621-nand":
[    0.688923] 0x000000000000-0x000000080000 : "Bootloader"
[    0.702948] 0x000000080000-0x0000000c0000 : "Config"
[    0.712674] 0x0000000c0000-0x000000100000 : "Bdata"
[    0.722351] 0x000000100000-0x000000140000 : "factory"
[    0.732261] 0x000000140000-0x000000180000 : "crash"
[    0.742011] 0x000000180000-0x0000001c0000 : "crash_syslog"
[    0.752375] 0x0000001c0000-0x000000200000 : "reserved0"
[    0.762452] 0x000000200000-0x000000600000 : "kernel_stock"
[    0.830322] 0x000000600000-0x000000a00000 : "kernel"
[    0.897811] 0x000000a00000-0x000007f80000 : "ubi"

Any help is much appreciated. Simply reading through the wiki pages makes me appreciate your work a whole lot! I mean, this is hard stuff and I don’t know how you’re able to figure these things out! :smiley:

It seems that no flash succeeded.Can you access in the browser? If yes ,you need flash again;if no , you need Google

No, cannot access
I tried for a good while, then restored to stock firmware 2.0.722 using xiaomi restore tool, then followed the easy guide again. I'm able to SSH to, but on browser I get nothing..
Google doesn't help me. It points me back to these pages, and this seems to get too difficult for my skill level.

If I don't get this working, I guess I'll have to restore stock firmware.. I was just hoping to get rid of stock firmware limitations..

Can you provide a screenshot of "Details" under "Ethernet" and you need to be connected to the Internet

ATM I'm unable to access internet via the AC2100 router.
I assumed that's because of the not yet completed setup.
Should it be working right away? I'm using mobile internet on another computer right now..

Sorry, my bad.. Internet works. Here are the ethernet settings. I've tried also with different endings 192.168.2.x

Näyttökuva 2022-12-06 kello 12.51.10

It may be that Luci is not installed. You can try it---- ssh to, opkg update & opkg install luci

That was it! Beautiful, thank you so much!
(Might be good to have that in the end of the easy guide for the more simple-minded such as me. :smiley:

Glad to help you

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.