OpenWrt installation on Linksys MR8300 v1.1 Firmware


I just bought a Linksys MR8300 v1.1 router that is running firmware and I can't get OpenWRT to install.
I have tried via the Linksys GUI manual update as described in the MR8300 OpenWRT page.

And tried using the link

Both methods give me an error trying to flash Open WRT 22.03.2 and say it is an unsupported firmware.
Has anyone had any luck flashing OpenWRT on a firmware above 1.1.8 as noted on the hardware page?

I have been searching and reading most of the day and have not found a solution yet.

The error when using the "fwupdate" link is....
"result": "ErrorSignatureCheckFailed"

When using the GUI I get....
Unrecognized file name, but I can select Yes and pass this error.
Then it appears to install but gives an "Invalid firmware file" error

I have not tried the TFTP method.

Thanks for reading and let me know if you need more information.


Try older openwrt images, but tftp is usually the safest bet when flashing...

Have you tried shortening the name of the factory.bin image to something like… factory.bin?

I know some OEM GUI’s are peculiar with character length and OpenWRT image names are quite lengthy. :man_shrugging:

1 Like

Mine has firmware and, I'm able to install OpenWrt with GUI.
Try to disconnect from WAN before booting, than uncheck automatic firmware update.
Which version is it currently running ? 1.1.8 or did the router self-updated to 1.1.10 ?
Considering that the goal is to use Openwrt, there is no interest in updating the router OEM firmware for safety reason. Newer versions may lock the possibity of installing OpenWrt.
Even if it sounds foolish, are you sure you have flashed the factory file, and the MR8300, not the EA8300 ?

EDIT : even if the flash is claimed invalid, have you tried to manually switch to the other partition, just in case it boots ?

It is currently running firmware I have seen the update to 1.1.10 but I have not allowed it to update automatically.
WAN was disconnected the first time I tried to flash but I will try that again.
I have tried to rename the OpenWRT firmware to factory.bin and I tried naming it the same as the Linksys firmware file and tried to change the extension to .img like the factory image.
Double checked and I am using the MR8300 firmware. Should I try the EA8300 firmware?

I am happy to hear that you managed to flash with a newer firmware. That gives me hope!

Thanks everyone, I'll keep trying.


Thank you for making me recheck my file!

Turns out I am just an idiot and was rushing to get OpenWRT running. I downloaded the wrong file and was trying to flash the upgrade file instead of the factory.bin file.

Using the correct file all went as it should have and I am running OpenWRT now!
Now to setup AdGuard Home.

Thanks again everyone!

Haha :wink: It had happened to everyone.
I would recommend to keep OEM firmware on one partition. You will need to flash a factory for OpenWrt, than restore the settings. Install luci-app-advanced-reboot it wil allows you to reboot easily to Linksys OEM.
Keep OEM firmware version 1.1.8, don't even try to update. There is no warranty that 1.1.10 allows to flash.
Enjoy your device.

Advanced reboot installed! Thanks again.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.