OpenWrt installation on Linksys EA7500v2

I have installed a SSH-only version of OpenWrt onto my router. It is working via ethernet, but I would like to restore it to factory firmware or install a graphical version of OpenWrt.

I have tried "scp (name of bin).bin root@" (without quotes)

and then

"sysupgrade -v /tmp/(name of bin).bin" (without quotes)

thing is, the graphical Openwrt firmware is in multiple bins, which are named

I have tried flashing the "sysupgrade" one, but the router terminates all SSH connection until I restart it.
(For the record, my router is EA7500 V2, not V1)

I apologize if formatting is awkward, I tried to space everything out so that it is clear and not confusing.

The router is still in beta, there is no firmware with graphical UI available yet.

You need to install snapshot, and manually install the web UI afterwards.

Just to add to what @frollic said, there shouldn't be a need to manually restart to regain ssh connection, terminating the connection after sysupgrade is normal, try waiting 3-5 minutes after sys upgrade and then try ssh again, it should connect without manual restart.