OpenWrt installation on GS1900-10HP

Hello everyone :wave:, I'm new and needed a PoE Switch so I ordered after searching through the Forum/Wiki a Zyxel GS1900-10HP. I also bought this (https://www.amazon.de/gp/product/B07WX2DSVB/) UART-Adapter and connected the Switch (I would say) correctly with the adapter. I rebooted several times with/without TFTP (atftpd) running (as root), debugged the Adapter by bridging RX/TX on the Adapter-PINS and on the Cable, turned the cables to use the other part of the cable/cable-connectors to check if it has a fault (as it is new). I tried using the Adapter (detected as ttyUSB0) with screen/minicom - baud rate was set as proposed in the wiki. Firewall has open Port 69/udp.

Also I set my Laptop which was connected on eth1 of the switch the 192.168.1.111 like proposed in the guide, I saw another IP 192.168.1.1 and was wondering as there is no second IP mentioned in the generic tutorials in the wiki for TFTP - what should I do with this?

So I'm really clueless, what I'm doing wrong? There is just nothing showing up when the switch is powered on and it does not make any difference if I fast/slow/constant/not press or hold the space key. Can you give me a hint what I can try?

which wires did you connect between the TTL and the switch ?

RX, TX, GND ?

The standard initial configuration of the RTL devices was changed and is now the same as every OpenWRT device. So the second device with 192.168.1.1 can be the switch with OpenWRT if you have already installed it via the web-interface.

don't think OP's gotten that far ....

1 Like


I attached two photos of my wiring (white - VCC 3.3V, brown - TX, orange - RX, black - GND) and also had the chance to try a different UART-Adapter (see Images) but still I get nothing (not even unreadable data) when booting the device attached with serial and opened with screen/minicom.

I tried again with and without pressing or holding space. Is it enough to connect just by Serial to check if I get any output/serial connection working, or will the device only show something when I successfully interrupted the bootloader, and finds a TFTP-Server?

I have an OpenWRT based Router but it's used in a different Subnet (10.10.XX) and not connected with the switch. Would it be enough to have the client with 192.168.1.111 with tftp running or is this second device required?

This is wrong! You must never connect the 3.3V or 5V power out of your UART to USB adapter to any other powered device. One of these devices is very likely to get fried, because whichever device has a slightly lower 3.3V or 5V level or even worse if you connect to that other device's GND will suck out current from the power pin of the power supplying device until that device's UART burns out, there is typically no current limitation, especially with cheap USB/UART dongles. If you are very lucky there is a current limiter somewhere, so maybe there is a chance.
Anyway: Only connect the the lower pins on the router to GND (lowest, black), then TX (brown), then TX (orange, 2nd from top). Do not connect the topmost pin of the router.

3 Likes

Thanks very much from a beginner view this wasn't really clear from the wiki :see_no_evil:

I had luck it seems, after wiring up like you told me (keep Orange as RX as there are not two TX?) I'm successfully into u-boot :partying_face:

1 Like

You got lucky :wink:

You could just as well have fried something ....

2 Likes