OpenWRT Imagebuilder is failing

I tried stable, snapshot and Attended Sysupgrade

padding image to 01170000
bash: line 1: 8: Bad file descriptor
Failed to open firmware file
sha256sum: /home/sinan/Desktop/openwrt-imagebuilder-ramips-mt7621.Linux-x86_64/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7621/tmp/openwrt-ramips-mt7621-unielec_u7621-06-16m-squashfs-sysupgrade.bin: No such file or directory
cp: cannot stat '/home/sinan/Desktop/openwrt-imagebuilder-ramips-mt7621.Linux-x86_64/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7621/tmp/openwrt-ramips-mt7621-unielec_u7621-06-16m-squashfs-sysupgrade.bin': No such file or directory
Skip JSON creation for non existing file /home/sinan/Desktop/openwrt-imagebuilder-ramips-mt7621.Linux-x86_64/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7621/tmp/openwrt-ramips-mt7621-unielec_u7621-06-16m-squashfs-sysupgrade.bin
JSON info file script could not find any JSON files for target

full log is here

On what host OS are you running the imagebuilder? Could the disk getting full while running the builder?

1 Like

Than it's related to your OS/environment. I can read "vbox" as host, which lead me think you are running within a virtual device.

I said I tried Attended Sysupgrade as well

I created ticket on Attended Sysupgrade repo but I believe it's related to ImageBuilder because I get the same error on my PC. @aparcar can you take a look?

Should I read: "please notice that I tried Attented sysupgrade as well" ?

I have just tried to build with the same command and run into the very same error. Have you tried to use less packages to find which one is faulty? I did : try without luci-app-samba4. You can now narrow your field of search.

Samba is so large that it is problematic. In some cases it has also erroneously caused the image size to grow into tens of megabytes.

Ksmbd is a newer smaller replacement.
(luci-app-ksmbd in needed, and it installs kmod-fs-ksmbd and ksmbd-server. Ksmbd-tools might also be needed )


I tried both. Ksmbd is not as performant as samba4 is USB3 or SATA3 port for external disk? - #9 by bahtsiz_bedevi
But anyway, I can install samba4 later. Imagebuilder script should give more meaningful error reports to the user.