OpenWrt FritzBox 7362SL

That or it simply is not yet configured correctly. Could you please post the output of the following commands (could be quite long):

cat /etc/config/network #make sure to replace your actual password with the string PASSWORD and your user name with USER
dmesg
logread

maybe that gets s further along...

https://pastebin.pl/view/aeb85a9c

Is my network config wrong?

Seems you have two dsl wan ports set up?
dsl and wan_dsl0_dev, did one of them get auto generated?

It could be. I will fresh install and show you the network config ...

now, its lokk like this. is this ok?

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde1:0965:fb66::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option tone 'av'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr '38:10:D5:CC:56:6B'

config interface 'wan'
	option ifname 'dsl0'
	option proto 'pppoe'
	option username 'username'
	option password 'password'
	option ipv6 '1'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '38:10:D5:CC:56:6E'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'




Ah I see:

        option tone 'av'

try setting this to 'bv', at least on my line I get no sync with tone 'av'....

ok, i did.
but WAN (dsl0) there is a error:Network device is not present

by the way, are you german?

in ifconfig, i cant see dsl0

can you schow me your ifconfig?

root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr C8:91:F9:30:88:88  
          inet6 addr: fe80::ca91:f9ff:fe30:8888/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:241780889 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44330 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:200722721713 (186.9 GiB)  TX bytes:13322196 (12.7 MiB)

br-lan.2  Link encap:Ethernet  HWaddr C8:91:F9:30:88:88  
          inet addr:192.168.100.1  Bcast:192.168.100.255  Mask:255.255.255.0
          inet6 addr: fdd7:1458:e823::1/60 Scope:Global
          inet6 addr: fe80::ca91:f9ff:fe30:8888/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:41659 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44323 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3734857 (3.5 MiB)  TX bytes:13321450 (12.7 MiB)

br-lan.7  Link encap:Ethernet  HWaddr C8:91:F9:30:88:88  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:241739230 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:200718986856 (186.9 GiB)  TX bytes:0 (0.0 B)

br-modem2wan Link encap:Ethernet  HWaddr C8:91:F9:30:88:88  
          inet6 addr: fe80::ca91:f9ff:fe30:8888/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:316 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:70516 (68.8 KiB)  TX bytes:746 (746.0 B)

dsl0      Link encap:Ethernet  HWaddr 00:20:DA:86:23:75  
          inet6 addr: fe80::220:daff:fe86:2375/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:167855896 errors:0 dropped:1043506 overruns:0 frame:0
          TX packets:90124973 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:556500600 (530.7 MiB)  TX bytes:456359712 (435.2 MiB)

dsl0.7    Link encap:Ethernet  HWaddr 00:20:DA:86:23:75  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:166812390 errors:0 dropped:0 overruns:0 frame:0
          TX packets:74926838 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:182165469394 (169.6 GiB)  TX bytes:19602492922 (18.2 GiB)

eth0      Link encap:Ethernet  HWaddr 02:1E:77:64:99:29  
          inet6 addr: fe80::1e:77ff:fe64:9929/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1508  Metric:1
          RX packets:74968516 errors:0 dropped:0 overruns:0 frame:0
          TX packets:166856726 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3026691895 (2.8 GiB)  TX bytes:1165448306 (1.0 GiB)

lan1      Link encap:Ethernet  HWaddr C8:91:F9:30:88:88  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan2      Link encap:Ethernet  HWaddr C8:91:F9:30:88:88  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan3      Link encap:Ethernet  HWaddr C8:91:F9:30:88:88  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan4      Link encap:Ethernet  HWaddr C8:91:F9:30:88:88  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:246132 errors:0 dropped:0 overruns:0 frame:0
          TX packets:246132 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:19198505 (18.3 MiB)  TX bytes:19198505 (18.3 MiB)

wan       Link encap:Ethernet  HWaddr 02:1E:77:64:99:29  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:74968499 errors:0 dropped:0 overruns:0 frame:0
          TX packets:166856709 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:18857126315 (17.5 GiB)  TX bytes:185181590856 (172.4 GiB)

root@OpenWrt:~# 

But I have this configured as bridged-modem, bridging dsl0.7 with wan.7.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd7:1458:e823::/48'
	option packet_steering '1'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'
	option ds_snr_offset '0'
	option tone 'bv'
	option firmware '/etc/config/vr9-B-dsl.fb7490-07.28-5.9.1.4.0.7.bin'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'dsl0.7'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config device
	option name 'lan1'
	option macaddr 'c8:91:f9:30:88:88'

config device
	option name 'lan2'
	option macaddr 'c8:91:f9:30:88:88'

config device
	option name 'lan3'
	option macaddr 'c8:91:f9:30:88:88'

config device
	option name 'lan4'
	option macaddr 'c8:91:f9:30:88:88'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.100.1'
	option device 'br-lan.2'

config interface 'wan'
	option device 'dsl0'
	option proto 'none'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

config device
	option type 'bridge'
	option name 'br-modem2wan'
	option bridge_empty '1'
	list ports 'br-lan.7'

config interface 'modem'
	option proto 'none'
	option device 'br-modem2wan'
	option force_link '1'
	option defaultroute '0'
	option peerdns '0'
	option delegate '0'

config bridge-vlan
	option device 'br-lan'
	option vlan '2'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '7'
	list ports 'dsl0.7:u*'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-modem2wan'
	option vlan '7'
	list ports 'br-lan.7:t*'

config device
	option type '8021q'
	option ifname 'wan'
	option vid '7'
	option name 'wan.7'

config device
	option type '8021q'
	option ifname 'dsl0'
	option vid '7'
	option name 'dsl0.7'

root@OpenWrt:~# 

And again I am on a O2 VDSL2@PTM 100/40 link (where Deutsche Telekom operates the physical link).

do i have to use a firmware, like you?

option firmware '/etc/config/vr9-B-dsl.fb7490-07.28-5.9.1.4.0.7.bin'

The next thing, I needed is crypsetup. Cryptsetup doesnt work, too.

Not sure, but well possible. In my case I need a vectoring capable firmware otherwise I only get a fallback profile with around 20/3 Mbps instead of the 116/37 I get with the correct firmware....

No experience with cryptsetup, maybe post that question in a new dedicated thread with an appropriate title?

No, cryptsetup not works. With freetz all work fine. But there are no iptables...

But look at this. My modem should be supported:

26	AVM	FRITZ!Box 7362 SL		Discontinued	21.02.3	DECT, FXS	Lantiq XWAY VRX288	Atheros AR9381	b/g/n	-	VDSL2	View/Edit data	avm_7362_sl	https://wikidevi.wi-cat.ru/AVM_FRITZ!Box_7362_SL

Just as an idea of getting more information out of your modem, here is what I put into /etc/rc.local:

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.


# default is 4, 1 and 2 are a firehose, 3 spits out something at retrains
echo "LOG 3" > /proc/driver/mei_cpe/config
echo "TRACE 3" > /proc/driver/mei_cpe/config

# get the DSL stats
#ubus call dsl metrics

# manual calls:
#dsl_cpe_pipe.sh help
#dsl_cpe_pipe.sh g997listrg 0

exit 0

Which made the DSL startup print a few things into the dmesg...

What version have not worked for you before you tried snapshot? Have you used/tried this release? https://downloads.openwrt.org/releases/22.03.0-rc4/targets/lantiq/xrx200/openwrt-22.03.0-rc4-lantiq-xrx200-avm_fritz7362sl-squashfs-sysupgrade.bin
This should be the most simple version to start from at the current release state.

I have tried many versions ... I will try your link and tell you if it works ...