OpenWrt for Xiaomi Mi Router 4C

thank u ,
solved on windows by MacTavishAO
after excute the command in cmd "pip3 install -r requirements.txt" \ note := open cmd in the same folder of the file requirements.txt

iget this install -r

and this
install -r__2

then the python is ready to use just dublle click on the script

and i got this
windows 2

it become more easy than linx

"Kernel 5.4.66 image"

Just for info, the wifi driver from the R4CM seems a little picky/buggy

Two 'old' machines experienced connectivity problems after 4 days. Router restart cures the problem.
No time to investigate on the router. Next time ai any.

1 Like

after following the instruction and installing openwrt on xia_4c successfully ,i want to install mwan3 but i got this error because of kernel is old ver.

thanks bro.
we waiting for update for Your creative work.

i installed ur openwrt in 24 device it is more useful than original ,and easy to use

1 Like

I'll try to give an update tomorrow.


I have the impression something is wrong with wifi driver. I have a setup in AP+STA mode, and router randomly disconnects from upstream AP with the following notifications in syslog:

wpa_supplicant ... CTRL-EVENT-DISCONNECTED .... reason=4

Do you know other kernel versions/drivers that work better? :slight_smile: Or any kernel bugs/patches, etc. For now it is completely unusable for me.

4, "Disassociated due to inactivity" },

First reply for a search......

Does not look like a bug and probably an explanation somewhere.


Today, another laptop screwed by the R4CM.
An XPSM1530, update a bunch a .deb for the Unbuntu distro, download speed ~ 15 20Kbs, rtc modem speed.
Turn on the ex access point (Fonera2), woup 2400Kbs as sound as wifi reconnected.

There is a BIG problem here.

Is it really hard to change operating frequency mode to N ?

In advanced settings there is a "Disassociate On Low Acknowledgement" option. IIRC it's enabled by default but I disabled it on my usage. Try that out.

First of all, thank you for the provided firmware. I was able to install
on my Mi Router 4c. Everything is working fine except the Wifi.
Just to confirm as someone has already posted, after about 6MB/s throughput via Wifi, the SSID is not visible to any clients (phones, laptops etc.). The device reports the Wifi adapter is enabled but it just hangs there.
However, if there is low bandwidth usage, it seems to be working normally. I can't tell where the threshold is.
I've tried the "Disassociate On Low Acknowledgement" option both on and off, no luck.
I'd greatly appreciate if there is some kind of an update to help with this.

For anyone facing the same issue, I've partially fixed the issue issue by limiting the bandwidth via QoS traffic shaping on wlan0 adapter to around 20Mbit/s egress and 5Mbit/s ingress.
It's not ideal, but at least it's stable.

Does Mi Router 4C pcb has usb pads? Can we solder usb port to pcb

Firmware seems unstable.
random LAN and WIFI issues.

Router 4A firmware is very stable but no WAN function.

so this means is possible to flash 4c using 4a firmware, how ? by the Luci or command line? thanks

Did you mean that you are running 4A's firmware on your 4C currently and you want to flash my build on top of it?


i was thinking that i can user 4a firmware on 4c router , cana I ?

First release of OpenWrt 19.07.4 STABLE

  • What's different then your previous releases ?
  • This version is built from v19.07.4 sources. As 19.07.4 is a release version, this build should be stable. My previous builds built on master (development) branch. Let's quote Wiki about master branch:
    "The development branch can contain experimental code that is under active development and should not be used for production environments. Snapshot images may support additional hardware; however, it is experimental, considered unstable, and sometimes won't compile."

How to install this on top of SNAPSHOT builds ?

1- Go to System -> Backup/Flash Firmware.
2- Under "Flash new firmware image" browse new bin and hit upload.
3- Don't keep any data and enable force install.
4- Click to install button

Google Drive


very nice release, thank you