OpenWrt for Linksys WRT1900ACS can't be upgraded

Well now, that wasn’t so bad! Thanks!!!

For Windows users the best option I’ve found is WinSCP.

@FCS001FCS , it is more a matter of removing the switch stanzas from the /etc/config/network config (switch, switch_vlan). Since you appear to be at default there really is not be much for you to do here. An example from a rango which will run as is (ignoring the obvious)

/etc/config/network
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxx:xxxx:xxxx::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'lan1 lan2 lan3 lan4'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'wan'
	option proto 'dhcp'

config device 'wan_wan_dev'
	option name 'wan'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan6'
	option ifname 'wan'
	option proto 'dhcpv6'

the other two files I listed are just device name changes as per what you will see in your OOTB network config.

Ok I think I got it. Thanks.

BTW what is "wan_wan_dev" used for?

It was required to get the HW MAC set for the WAN device, the mamba has to set both WAN and LAN devices. Should be in agreement with your actual HW.

Just a note: I have no idea what the bot generated images use for build parameters on compiling packages. You might want to look at anything you consider critical to your use-case. To point openssl if used

openssl engine -t -c -vv
openssl engine -pre DUMP_INFO devcrypto

or whatever...

I am on a WRT3200ACM Rango, is it the same?

The one I posted above is what the default config should like from a rango.

1 Like

Thanks, I got a Snapshot build done on Sunday and it worked fine (DSA=OK) but then I realised I forgot hostapd-common & wpad-basic since my wireless did not work.
I tried to build a new image but now there are big issues with the Snapshot buildbot:
"Heads up, new fakeroot package has failed in a major way in buildbot, and the phase2 packages buildbot has failed to build any package for master for 1-2 days."
I am trying to install the packages manually via Putty but I am getting errors. How do I force an IPK install and ignore the kernel matching errors?

BTW, what is the difference between arm_cortex-a9_vfpv3-d16 and arm_cortex-a9_vfpv3-d16?

I would suggest wpad-some SSL variant(wolf,open)

I think you are hooped until issue is resolved as Image Builder wants to fetch packages I think. SDK still builds, but...

See architecture change, but to fix that up you will have to go to the SDK rather than Image Builder. Basically means GCC has 16 instead of 32 FPU registers at its disposal.

Thanks, will wait a few days until the build-bot is back up and try again.

Hm, I apologize in advance for asking the following, but hey, one's got to learn. I've used davidc502 builds on my WRT1900ACS V2 for a long time and I've built it from source a few times from his .config file so I could make some tweaks. I just started using ImageBuilder because I'd like to move forward and use DSA per @anomeome earlier description on how to convert. Although I built a few builds with ImageBuilder I don't really know if I have a PACKAGES list which is complete enough to give me basic LuCI functionality and wireless. Any chance one of you could share your packages list to get me started properly?

If you follow the link off my avatar you will find images as I am currently running on wrtpac devices I use. Check the config.buildinfo and openwrt-mvebu-cortexa9.manifest files as to image contents.

1 Like

I don't mean to hijack this thread, but I ran into the 1.0-1.1 migration problem yesterday on my wrt1200, and after reading through this thread and the one @anomeome linked above I thought I would be ok running the force upgrade without keeping settings, but that resulted in no access, so I'm guessing I misunderstood and need to modify the network, system and firewall configs before upgrading (I think), would anyone happen to know if that's the case, and if so where I could find the new DSA configs needed for the wrt1200?

The new default DSA config is included quite normally in the image. Flashing without settings should result in a normally working router.

(Just remember that also WiFi is off by default in the regular OpenWrt)

1 Like

Thanks @hnyman, I'll give it another try with a new build when buildbot is back up and running.

Note that you can use the full normal toolchain right now, only the imagebuilder is affected by the buildbot difficulties.

1 Like

You are lucky. Packages for mvebu routers have been rebuilt a few hours ago...
https://downloads.openwrt.org/snapshots/packages/arm_cortex-a9_vfpv3-d16/

1 Like

Excellent, thanks for the heads up, I appreciate it.

@anomeome - Thanks for the advice. I got the image built with my basic packages and it seems to be working fine. Had to do a bit of back-and-forth to get all the packages I needed listed in the Build "make" command but I finally got to a workable image for my use.

DSA was painless as you said since I just did a clean install, got the new DSA network config file, then modified the old network config file to reflect the DSA settings in my last settings tar.gz and upload the settings to the new image. Worked good.

1 Like

Just wanted to mention that I made a new build and it worked fine this time, I'm sure I probably messed something up in the menuconfig on the last one, thanks again for the help @hnyman.