OpenWrt for Linksys WRT1900ACS can't be upgraded

I am not sure what has been changed. My Linksys WRT1900ACS can't be upgraded since a few months ago.

I downloaded openwrt-mvebu-cortexa9-linksys_wrt1900acs-squashfs-sysupgrade.bin but when I tried to flash the image via LUCI, it showed an error message:

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Currently I am on OpenWrt SNAPSHOT r13213.

I did flash image many times before with no issues.

some info, if you have already converted your config to DSA you should be safe to force.

Sorry, what is DSA? How to convert?

I did force upgrade before, but it did not boot. So I had to boot to alternative partition.

If you have not converted (and do not know what the DSA setup should look like) I would recommend taking a backup of your current setup, force a flash without keeping config, backup the OOTB config, reconcile:

  • /etc/config/network
  • /etc/config/system
  • /etc/firewall.user

changes from the OOTB config into you config, and restore that backup. Not hard to do.
As far as DSA, search this forum which has many relevant threads which should yield requisite information.

1 Like

Thank you for the information.

It takes time to configure openVPN with Pia. I will try when I have more time.

I've had a hard time finding a process for migrating from swconfig to DSA. Thank you for these steps, it actually looks pretty simple to change to DSA.

OK, I’m old, I give up - don’t understand OOTB :pleading_face:

Guarantee you that you ain't as old as me, (Out Of The Box), what gets generated by the default setup scripts on an install with no config, or what you might get with a run of firstboot (image dependant).

Don’t bet the bank on that :laughing: Feeling a little foolish considering I use the term (in full) on a regular basis. :smiley:

TFT (thanks for that), I can stop obsessing over what I might have missed in the conversation.

you can use "scp" to copy the file to the temp directory and then "ssh" to log into your router
if you are using windows I think that the free program "putty" contains ssh and scp and you can download it

scp [name of file] root@192.168.1.1:/tmp
ssh root@192.168.1.1

cd tmp
sysupgrade [name of file]

Well now, that wasn’t so bad! Thanks!!!

For Windows users the best option I’ve found is WinSCP.

@FCS001FCS , it is more a matter of removing the switch stanzas from the /etc/config/network config (switch, switch_vlan). Since you appear to be at default there really is not be much for you to do here. An example from a rango which will run as is (ignoring the obvious)

/etc/config/network
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxx:xxxx:xxxx::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'lan1 lan2 lan3 lan4'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'wan'
	option proto 'dhcp'

config device 'wan_wan_dev'
	option name 'wan'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan6'
	option ifname 'wan'
	option proto 'dhcpv6'

the other two files I listed are just device name changes as per what you will see in your OOTB network config.

Ok I think I got it. Thanks.

BTW what is "wan_wan_dev" used for?

It was required to get the HW MAC set for the WAN device, the mamba has to set both WAN and LAN devices. Should be in agreement with your actual HW.

Just a note: I have no idea what the bot generated images use for build parameters on compiling packages. You might want to look at anything you consider critical to your use-case. To point openssl if used

openssl engine -t -c -vv
openssl engine -pre DUMP_INFO devcrypto

or whatever...

I am on a WRT3200ACM Rango, is it the same?

The one I posted above is what the default config should like from a rango.

1 Like

Thanks, I got a Snapshot build done on Sunday and it worked fine (DSA=OK) but then I realised I forgot hostapd-common & wpad-basic since my wireless did not work.
I tried to build a new image but now there are big issues with the Snapshot buildbot:
"Heads up, new fakeroot package has failed in a major way in buildbot, and the phase2 packages buildbot has failed to build any package for master for 1-2 days."
I am trying to install the packages manually via Putty but I am getting errors. How do I force an IPK install and ignore the kernel matching errors?

BTW, what is the difference between arm_cortex-a9_vfpv3-d16 and arm_cortex-a9_vfpv3-d16?

I would suggest wpad-some SSL variant(wolf,open)

I think you are hooped until issue is resolved as Image Builder wants to fetch packages I think. SDK still builds, but...

See architecture change, but to fix that up you will have to go to the SDK rather than Image Builder. Basically means GCC has 16 instead of 32 FPU registers at its disposal.

Thanks, will wait a few days until the build-bot is back up and try again.