OpenWRT for EA3600v1?

Hi everybody,

Which firmware I should upload to my Cisco Linksys router (EA6300v1)?
Its spec is:

FCC ID: Q87-EA6400 IC: 3839A-EA6400

Thank you all!

https://firmware-selector.openwrt.org/?version=23.05.2&target=bcm53xx%2Fgeneric&id=linksys_ea6300-v1

Read the warning at https://openwrt.org/toh/hwdata/linksys/linksys_ea6300_v1

Thank you for your reply.
I downloaded your file but I got the screenshot error!

How can I resolve it do you think?

Thank you.

by following the post in the thread I linked to, to the letter ?