OpenWrt Firmware for Archer c6 v3.2

Thank you for confirming that the stripped stock image allowed you to revert the Archer C6 v3 back to the stock firmware!

Upon the first OpenWRT install, the default logon is "root" with a blank password. If you are unable to login this way, you may try to perform an OpenWRT factory reset.

To do so, after the device is powered on and you are able to see the OpenWRT logon screen, press and hold the "Reset" button in the device for at least then seconds and release it. This should clear all OpenWRT settings and remove any previous password. More details in the OpenWRT wiki here.

1 Like

Oh, i did that, however the Luci interface didn´t show (my browser show that server sent an empty response). I followed the instructions in:

I made a little bit of research and found that installing the package luci-ssl-nginx (instead of all others) allowed me to see the GUI but it didn't allow me to gain access due ¿main? faile damaged of XHR request timeout.

Just installing LuCI and accessing via http (not https) should work.

It might be an issue with the recent Snapshot builds (see SNAPSHOT: LuCI will not launch r17571 and r17581 on WRT1900ACv1)

I think we will need to build a stable release binary as snapshots are unpredictable.

1 Like

Yeah, was that... i tried yesterday with new snapshot and it worked since then.

5Ghz sometimes refuses to work, but i supose beacause ...well,snapshot.

Is any developer still working on adding this router to the 21.02 head to be included in a future 21.02.1 stable release?

Since the updated m76 drivers broke Wifi 5Ghz on this device and others devices (see here), it would be good to have it on an stable branch just as A6 v3 and C6U are already in 21.02.0 stable release.

BTW, I just realized that there are no internal pictures of this device on the web, so here you go:


Hey All,

I installed the latest snapshot and I cannot turn on wifi after that.
Even did the setup using uci

@dsouza I noticed the C6 V3 didn't make to the latest stable release of today.
Do you know if there is differences between C6 an A6 ? I heard A6 being Amazon exclusive clone of the C6. Are you aware of any differences ?

As far as I know they are the same device. I believe that flashing OpenWRT A6 v3 firmware on the C6 v3 could work, but I would not recommend it unless if you have an UART and skills to open the device and recover it via serial console (since it may brick your router).

Anyway, I am willing to try this during the weekend... :slight_smile:

I just flashed 21.02.1 Archer A6 v3 image on an Archer C6 v3.2 device and as expected it is working.

I had to "force" a sysupgrade from OpenWRT snapshot since it detected it was a different device. But the upgrade went OK and everything is working fine (obviously it started showing "TP-Link Archer A6 v3" on the status page.

Notice however that I (forced) flashed from OpenWRT snapshot C6v3 to OpenWRT 21.02.1 A6v3 using squashfs-sysupgrade image and I can confirm this works fine. However if you are flashing from stock firmware I cannot say it would work applying the A6 v3 squashfs-factory on a C6 v3.2 device. I think it would work but I have not tested.

1 Like

when will be stable version for this router? I mean LuCi preinstalled.

I tried to cherry pick these changes into 21.02 (#4280) but it seems they were rejected I have since lost track of the release. Not sure how to get that included once multiple releases are out.

Idk what to say,it is sad and bad for community.I was decided to purchase it.Because is cheaper then C6U.

I have instaled the snapshot version from 3 weeks ago, but last week I have tryed to upgrade to the last snapshot, but after that it starts to boot loop. But I can´t have the TFTP working to install a new firmware. Can anyone help me how to unbrick it?

Have you identified the serial port?

It's a known issue due to a Wi-Fi problem in some builds. This has already been resolved in the more recent builds.

To recover from this you must enter in Fail Safe mode by pressing the reset button before boot while power is flashing slowly and flash a more recent build.

1 Like

I have used The same process of the v2 Version. But It not working.
Turn on with The reset button, put my PC with and tftp, But no thing happens.

i think you must use info from git commit;a=commit;h=d22fb7f4fd833c420bc2ab34384862da0a6688b5

The TFTP Booting I don´t know how to acess this U-boot, I think that is using the serial, but I can´t find the pins on the board.

The second method of restarting 4 time before full boot, don´t work either.

What I discovered now, is the the Led sequence changes when I push the reset pin as son as the power led starts blinking, the it starts blinking fast and do not stops.
I have already tried with wireshar to see if have any attpempt of the board to connect any IP address, but no luck.

TFTP Booting

Setup a TFTP boot server with address
While starting U-boot press '4' key to stop autoboot.
Copy the initramfs-kernel.bin[1] to TFTP server folder, rename as test.bin
From u-boot command prompt run tftpboot followed by bootm.


Archer A6 V3 has recovery page activated if SPI booting from flash fails.
Recovery page can be activated by powercycling the router four times
before the boot process is complete.
Note: TFTP boot can be activated only from u-boot serial console.
Device recovery address:

This is fail safe mode, and you should be able to access via SSH to IP address See below for more details: