OpenWrt Firmware for Archer c6 v3.2

Thanks. Will try and reply.

The stable release for A6 is having issues with 5GHz is it working fine with snapshots on C6?

1 Like

The snapshots have an updated version of the MT76 (wifi) driver which in my experience is much better than the version included in the stable builds.

The only 5Ghz Wifi issue so far is the issue below, that at least in my case happens very sporadically and affects only one specific device.

EDIT: the TX Power configuration does not work (same as the stable build), it always work using max power regardless of the configuration, second issue below.

1 Like

Currently checking snapshot for A6v3, everything working fine till now.

1 Like

Sorry for posting about A6 instead of C6 in this thread but I think both the devices are essentially the same so this should apply to both. I'm using the snapshot since few days and the 5GHz issue has not come up. But I'm facing a weird issue both on stable as well as snapshot. Some changes made on the GUI don't get applied on "Save and Apply". Even rebooting does not help. But things work when I do 'uci commit firewall' followed by a firewall service restart from the SSH terminal. Has any one faced anything similar? I can share the exact situations when this happens if necessary.

Since Jan 19th 2022 snapshot builds replaced firewall (iptables) by firewall4 (nftables) by default.

See the post below, it seems that there is some issue in LuCI firewall app with firewall4. I do not know if this has been resolved, but could be related to what you reported:


Does your C6 running without issues? I'm still having issues with C6 v3.2 on latest snapshot. Wireless interfaces are constantly disabling and enabling itself.
Log is filling with these lines

Wed Jan 26 15:34:01 2022 daemon.notice hostapd: Remove interface 'wlan0'
Wed Jan 26 15:34:01 2022 daemon.notice hostapd: wlan0: interface state ENABLED->DISABLED
Wed Jan 26 15:34:01 2022 daemon.notice hostapd: wlan0: AP-DISABLED
Wed Jan 26 15:34:01 2022 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Wed Jan 26 15:34:01 2022 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Wed Jan 26 15:34:01 2022 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Wed Jan 26 15:34:01 2022 kernel: [  530.877069] device wlan0 left promiscuous mode
Wed Jan 26 15:34:01 2022 kernel: [  530.881677] br-lan: port 6(wlan0) entered disabled state
Wed Jan 26 15:34:01 2022 daemon.notice netifd: Network device 'wlan0' link is down
Wed Jan 26 15:34:02 2022 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Wed Jan 26 15:34:03 2022 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->ENABLED
Wed Jan 26 15:34:03 2022 daemon.notice hostapd: wlan0: AP-ENABLED
Wed Jan 26 15:34:04 2022 daemon.notice netifd: Wireless device 'radio0' is now up
Wed Jan 26 15:34:04 2022 daemon.notice netifd: Network device 'wlan0' link is up
1 Like

Please do a clean install and then check.

I always do clean flash via sysupgrade -n
I have built customized firmware without luci & firewall and cofigured router as full bridge (lan + wlan) with only ssh management. I'm using the same config on other routers (Archer C6 v2, Xiaomi R4C and other models) without any issue. I don't know what could cause this issues.

I am new to openwrt .i would like to install the snapshot version on my archer c6us v3.2 . Plz let me know if i get into any problems if i install the snapshot and also i need to know which file should i use to upgrade from stock firmware.

Current snapshots (as of February 1st 2022) are bricking these devices. You should wait until this problem is resolved before trying a snapshot image. More details below.

1 Like

Thanks for your fast reply...
When we can expect stable release for the device

Aight, I started this thread last year facing the same issue and have since then used the Snapshot released back in Jun21.
My original need was to set this one up as a secondary router with VPN to watch content that's unavailable in my region but I couldn't get Open VPN to work on this snapshot. That project dropped after a couple of failed attempts, I think the builds from then on have only made the firmware unstable.
My suggestion: either stay with stock or go back to June snapshot. I can share a copy if needed but I think it's available on the links above.

Question : why do you want to install openwrt, I mean what's the use case. See my case was VPN tunnelling for my second router and set up a Roku stick to watch free stuff :wink:
Since I failed at that, I have used an earlier router I had for that.
As for the openwrt on this one, I used it for 2 purposes

  1. As a repeater or my primary WiFi router to provide bridged lan to my pc (since I couldn't run that long cable and my PCs wifi signal wasn't good enough for pings needed for FPS gaming). That worked beautifully.. I used relayd for that.
  2. As an access point to my primary router. But I only use the 2.4G radio on the device. (I dint need the 5G).
    For both these, the router works just fine.

Unless your use ase involves unlocking a specific config it's pointless to install openwrt without testing.

I am happy to even test something to verify if the config works on the old snapshot build but I need to know the use case...

1 Like

You can use the stable for A6v3, they are the same hardware.

BTW, the "bricking" problem with snapshot builds have been resolved. New builds from Feb 2nd and on should not brick the devices anymore.

However new builds are including the new firewall4. I am having various issues with firewall4...

1 Like

Thanks for the update...have u tried latest snapshot? Is snapshot version stable than the stock version.i have ping spikes on 2.4 ghz wifi, will installing the snapshot able to solve the problem.

No i haven't updated to latest snapshot as my router is working perfectly with the June 2021 snapshot. No need to take chances.. No ping spikes no signal issues....

Can anyone provide me a non bricking snapshot with firewall3 link.i dont have much technical knowledge to unbrick the router if something went wrong, so i prefer some snapshot version that is tested and working

I have an Archer C20 v5 connected as dumb AP to the c6. Both have OpenWRT installed. The issue I am facing is that the C20 disconnects from the C6 randomly at least once a day. The Internet light starts to blink and I have to reconnect the LAN cable to fix it. I also had this issue when the C20 had stock firmware. On the other hand, C20 worked perfectly fine as an AP with my ISP router. So, there could be some issue with the C6 snapshot? Please help.

Instead move to A6v3 stable.. it's the same hardware.