OpenWRT factory binary for D-Link DAP-1325 (first time install)

I want to load OpenWRT on a D-Link DAP-1325 (A1) to use as dumb AP with my main router (which is already running OpenWRT).
However, the Techdata page for the device DAP-1325 only lists an OpenWrt Upgrade URL. There is no OpenWrt Install URL.

I can access the Recovery Mode web page (provided by the OEM firmware V1.07), but am reluctant to try the sysupgrade binary directly on the OEM firmware. Is this what I need to do?
If not, where do I find the OpenWRT factory binary for first time install?

Any assistance appreciated. :slightly_smiling_face:

1 Like

I state that I do not have the same device as you.

I would wait for news from someone who has the same device as you, to know the possible problems related to the installation.

Thanks @ncompact for the fast reply :+1:
Now I know there is a firmware selector tool.

I assume I first flash the kernel, boot it and then flash the sysupgrade from there, correct?

if you have doubts about the installation, I would wait for someone who has the same model as you,

but still the procedure is the one described in the manual ...

I don’t have this model but DAP-1610, which is exactly the same but has an additional 5ghz radio.

Just flash the sysupgrade from either oem and if that doesnt work you have the web recovery at It’s impossible to brick this router, so no worries.

If you ever want to go back to oem, you will have to do that from the web recovery, but beware there might only 1 firmware version that the web recovery will accept. For DAP-1610, only the original 1.01b2 version works, it might be similar with DAP-1325.. although OpenWrt pretty much works without a hitch so I don’t know why you ever would do that.

With only 8MB of flash space you may not be able to install very many extra packages. However to use as a Dumb AP it should work. 8MB devices may be deprecated for the next stable release 23.05 when that happens.

Simple Google search gave this:

Thanks @theMan

I flashed the sysupgrade and all is working fine :smiley:

1 Like

Thanks for the replies @jc1685 .

Yes, I realise this is not powerful hardware, but all it needs to do is to provide WiFi coverage for an area where the main router's signal is too weak. It is connected via Ethernet cable to the main router (which the OEM firmware does not support well).
Should be fine to stay at an older OpenWRT version for some time.

My simple Google also found the thread you linked, but it did not tell me anything I did not know already.
It still was not clear to me that you could just flash the sysupgrade rather than a full install when replacing the the OEM firmware.

Slowly but surely this newbie is learning with the help of you guys on this forum. :+1: :smiley:


Just out of interest, how did you know that the DAP-1610 has OpenWRT support?
It is not listed in the table of hardware and the firmware selector does not find it either.

I added it myself and built from source.

1 Like

You should create OpenWRT documentation for it so that the rest of us, who don't have a deep enough understanding of the hardware level, can shamelessly grab it and benefit from your hard work. :wink:

I might manage to compile from source on the target hardware, but how to mod the code for specific hardware support is beyond my skill set at present :slight_smile:
I assume you compiled on a Linux box which has different hardware / architecture too.

Without people like you, open source would never have worked.

1 Like

Thanks for the kind words but it was mostly supported already. I did some investigations to see if the partition layout lined up with DAP-1325, then added support for the second radio. No big deal. I meant to add a PR for this but I’m a bit lazy:-)


All software developers are by definition lazy. You need to be, else you won't spend time writing code to avoid doing repetitive tasks manually. :wink:
Plus who needs documentation if you can just read the code!

Anyway enough rambling on a solved topic... :speak_no_evil:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.