OpenWRT Dumb AP Setup and Roaming

I am trying to set up two dumb APs on openwrt. I set a static IP on the br-lan interface and made sure to add a custom dns server for DNS resolution. I used the guide to disable firewall, dnsmasq and odhcpd. It mentions to also rm /usr/sbin/wpa_supplicant but I don't know if I need the wpa supplicant.

My end goal is to setup the same configuration on the other dumb AP with the same SSID and channel so clients can roam from upstairs AP to the downstairs AP. The SSID is setup with Encryption: mixed WPA2/WPA3 PSK, SAE (CCMP)

"wpa_supplicant" is only needed for a wifi client setup.

1 Like

Regarding your roaming goals...
I just addressed that in this other thread.

Be aware that mixed mode doesn't work well in all circumstances. Some (client) devices end up with connection issues, even if they support both WPA2 and WPA3. There is something about mixed mode that just tends to be problematic in some situations. The least problematic case is to use either WPA2 or WPA3, but not mixed mode. But if mixed is working for your situation, feel free to keep using it.

1 Like

Thanks, I watched the video and made change suggested by you and the video. Intially I tried setting up the second AP on channel 100 but that channel is a radar dection one so I guess it would just disable it.

Upstairs - 80MHz

          Mode: Master  Channel: 36 (5.180 GHz)  HT Mode: VHT80
          Center Channel 1: 42 2: unknown
          Tx-Power: 23 dBm  Link Quality: 36/70
          Signal: -74 dBm  Noise: -113 dBm
          Bit Rate: 334.8 MBit/s
          Encryption: mixed WPA2/WPA3 PSK/SAE (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/n
          Hardware: 168C:0056 0000:0000 [Qualcomm Atheros QCA9886]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

Downstairs - 40MHz

          Mode: Master  Channel: 149 (5.745 GHz)  HT Mode: HT40
          Center Channel 1: 151 2: unknown
          Tx-Power: 30 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -113 dBm
          Bit Rate: unknown
          Encryption: mixed WPA2/WPA3 PSK/SAE (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/n
          Hardware: 168C:0056 0000:0000 [Qualcomm Atheros QCA9886]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

Setting up channel 100 error

daemon.notice hostapd: Frequency 5500 (primary) not allowed for AP mode, flags: 0x1979 RADAR
daemon.err hostapd: Primary frequency not allowed
daemon.warn hostapd: phy0-ap0: IEEE 802.11 Configured channel (100) or frequency (5500) (secondary_channel=1) not found from the channel list of the current mode (2) IEEE 802.11a
daemon.warn hostapd: phy0-ap0: IEEE 802.11 Hardware does not support configured channel
daemon.err hostapd: Could not select hw_mode and channel. (-3)
daemon.notice hostapd: phy0-ap0: interface state UNINITIALIZED->DISABLED
daemon.notice hostapd: phy0-ap0: AP-DISABLED
daemon.err hostapd: phy0-ap0: Unable to setup interface.

So try channels that are outside the DFS range.

I did, I ended up using 149 as you can see from the output in the previous reply.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.