OpenWrt does not connect to Internet

Thanks for help. Since I can not connect to my device from another, I can not copy and paste any text. I must to type whole text and I wont be able to copy the output. So, I guess I am stuck.

Although it is based on OpenWrt, this is not an official version of OpenWrt. It is clearly a forked and customized version (that is also running on 21.02.3 which is out of date).

Please direct your questions to the maintainers of "PrivateRouter", or download and install an official version from the official OpenWrt downlaods site and use the official installation guide to get up and running.


I’ve decided to go with official version but I am stuckted at the same point. I am not able to connect to internet in OpenWRT.

What NICs does the system have ?
You might need additional modules to get networking up and running.

I bought that mini-pc

And put that wifi card (6E version)

Both ethernet and wifi is working with Linux Mint on mini-pc.

Seems you need the igc driver for the wired nic, but it should already be included in the image.

Did you try all the wired ports of your device ?

The ax200/210 wifi card is only usable as a client, unless you like slow APs.

1 Like

Yes, try every ethernet port with your PC set to defaults ("Obtain IP Address Automatically", aka DHCP). The kernel's enumeration of the ports may not match the manufacturer's labels on the case.

Do you have a local keyboard and screen or a serial console cable (it looks like a Cisco type plug). On the local terminal, run ip link show to see if any Ethernet ports are recognized. There should of course be four, named eth0 up to eth3.

1 Like

Lol (!) I was thinking about buying this model.
For intel 225 NIC, you need kmod-igc. It should be there by default in 22.03.3.
For your wifi card (intel AX210): bad news. I remember that intel's wifi NIC can't be used as an AP. Maybe someone else can confirm/improve the matter.

... or just a regular display, it got HDMI and DP.

1 Like

I have setup three tiny PCs such like this one. Everytime the enumeration matched the manufacturer labels. I have always got LAN on eth0 and WAN on eth1. On the other hand, I have homemade routers with several NICs inserted (+motherboard) and never had the same enumeration, even when using the very same NIC card onto another PC. It's not an obvious matter :wink:

I’ve tried all the LAN ports but nothing changed.

Unfortunately I have none of them.

Then run logread -f on the console, while you unplug and reconnect the Ethernet cable, one port at the time.

1 Like

Mine is i226 version.

Maybe you should give us more information about our config.
Maybe should make a screenshot from the output of all these commands:

ip link
ip -4 addr 
ip -4 ro li tab all 
ip -4 ru

One screenshot for every single line.
Did you change something from the default config?
Can you give us more information about your network? Is the openwrt device the main router? Are there other routers? I love drawings/diagrams ... :smiley:

Driver should be the same.

I solved the problem somehow. Thanks all for your suggestions.
Looks like I had a bad cable.

I managed to install OpenWRT and now I can access it via other ports. You guys said I have a wrong wifi card. Which card should I buy for AP mode?

For hardware recommendations please open a new topic in the Hardware Questions and Recommendations category of this forum.

Thanks! :slight_smile:

1 Like

ath10k based cards are very good. You have some models here.
Choose according to the connection and your need.
One may suggest another platforms (mediatek ...)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.