OpenWrt DLNA Media Server HOW To page

Per the OpenWRT page

DLNA Media Server

I tried: opkg install minidlna
the terminal returned:

Collected errors:
 * check_data_file_clashes: Package libbz2-1.0 wants to install file /usr/lib/
	But that file is already provided by package  * libbz2
 * opkg_install_cmd: Cannot install package minidlna.

When I researched:

openwrt luci lede minidlna install opkg

nothing comes up that reflects opkg's saying "cannot install".
Is it me?

Pretty sure that you need to build your own packages and preferably with ffmpeg4 as you'll only get parial media support otherwise.

Please make this easy for me. I am unskilled in building packages. Especially on OpenWRT. Your answer shows that much more than merely adding ffmpeg4 is needed to get MiniDLNA on the router. Is there one page or website that has clear and precise instructions for the job necessary?

What is that DLNA Media Server page good for? That's confusing.

That information is provided on the page under "possible usage limitations". Otherwise, I'm unsure of what @diizzy is referring to.

So let's troubleshoot your actual problem now.

What version of OpenWrt are you running?

No clue what this means, it's definitely not valid OpenWrt syntax.

I can only hope that I have guess correctly and this is what you are asking about:

TP-Link Archer C7 v2
Qualcomm Atheros QCA9558 ver 1 rev 0
OpenWrt SNAPSHOT r7066-060e1ecefa / LuCI Master (git-18.151.24607-5452cc2)
Kernel Version 4.9.102

Problem? I have a external usb hard drive that I would like to watch recordings on. I use both Debian 10 and have Win10 laptop. Debian is ethernet cable, laptop is wifi. It's not I insist on MiniDLNA. I only want to deliver media (only recorded TV, so .mp4) to the 2 'puters.

  • Upgrade your snapshot (which is extremely old)
  • Try install again

Snapshot are only good for package installs for ~24 hours only. So install all packages you'll need immediately after the next update.

I have


and cannot find the "codename" to run sha-256 per:


the desired result is that the downloaded firmware filename is listed with "OK" afterwards

via sha256sums

sha256sum -c sha256sums 2> /dev/null | grep OK

It depends on libffmpeg which unless changed recently is having troubles identifing "common" formats due to being rather stripped down by default.

I have no clue what you're saying. Are you saying you cannot read the checksum file to verify your download?

Have you tried just using a web browser and looking there?

The syntax would be:

sha256sum openwrt-18.06.5-ar71xx-generic-archer-c7-v2-squashfs-sysupgrade.bin

I'm not sure why you stripped the file extension, so I'm just making a guess when I used .BIN.

I'm not sure why you're downloading a version 15.05 checksum list to verify a 18.06.5 file; but that's incorrect.

I have to write the sha-256 line to have the .bin "code name". Is that "Busy Box" or "Barrier Breaker"? Some other?

Fwiw i'm on 18.06.5 and minidlna installed fine, the libbz2 version i have is 1.06-5, so you seem to have an old version apparently for some reason. The only thing i can think of would be to uninstall minidlna (or luci-app-minidlna if that's what you have), uninstall libbz2, remove /etc/config/minidlna and reboot, then try installing minidlna (or luci-app-minidlna if you're using luci) from the 18.06.5 repos and see how it goes.

OpenWrt doesn't use names anymore, so the syntax @lleachii pointed out would be what you need.

1 Like

I found it to be 18.06.5, but could not find the substitution for chaos_calmer.

FULL STOP. on the sha-256. I have it in the computer and gtkHASH shows a clean d/l.

Now on to miniDLNA

1 Like

ahhh . . . update maybe installed. I cannot get to the net from the router/wifi. Pinging shows a response but I can't login at

Since I can't get to the router's admin page, how do I reset the router to the previous firmware? I have cold booted both modem and router. Twice.

To defaults, on the command line:


If there were some bad setting or version incompatibility, this would clear them. Make sure you have a backup!

1 Like

firstboot and reboot DONE.

I can access the router via ssh terminal. Password working

I cannot access the router via it's GUI. Same password as above for terminal, but NOT working.

Try clearing your cookies and cache and removing the old saved password if you're using a new one.


And to be clear, there is no password if you did firstboot/reboot.

1 Like