OpenWRT deutsche glasfaser

Hi everyone,
I recently decided to change my router from fritzbox and move to another. On advice, I bought a router on openwrt GL-AX1800. Thought everything would be simple, but when trying to change the router, the new one does not receive any data from the fibre optic converter. Resets and similar dunces didn't help. In trying to figure out what's wrong, I've come across 3 different judgements. The first one says to use pppoe, the second one says to just add a vlan tag, the third one says to create a rule in the firewall between van and lan.
I am using deutsche glasfaser.

I would be very grateful if you could tell me what and how to configure. I didn't understand the console output, but in the web interface, in the VLAN tab, the system writes that there is no known topology.

Was that your own Fritzbox or a router supplied by DG? I seem to recall than with DG one needed to tell them if one wanted to switch top one's own router (I also think one had to return the DG router). However I was never a DG customer so this is all hearsay...

The router is my personal router. I have also done the same through mac address spoofing, but the result is the same.

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

Deutsche Glasfaser works fine with OpenWrt (there is a quirk (but in DG's implementation) with IPv6, but that affects (=breaks) some other firmwares much more (hello Lancom, Sophos, etc.), but GL.Inet's firmware is NOT OpenWrt, and ipq60xx is not supported yet.

DG does lock onto your router's MAC though and it takes multiple hours (more than 2, probably in the 6-8 hour range) to accept a new MAC. And, yes, they do provision the lines for their own- or customer supplied routers differently.

1 Like

Thank you for your clarification.
I have already enquired with Routrea and they gave the following explanation:
Initially, the router has their proprietary shell, but they also leave the option to enter the proprietary interface of Openwrt - Lucy.

I'm a customer of "Deutsche Glasfaser = DG" too. And I'm running a NanoPi R2S with plain openwrt as router. Nothing to configure.
I had just to connect the cable to the wan port and power on the R2S.

Do not use PPOE with DG.

About the VLAN question. The DG uses no VLAN's if you are a customer with privat router.
But if you have ordered your fiber line with a router provided by DG then there are 2 VLAN's. So if you are replacing a router from DG, without changing your account to "private router" you have to configure VLAN.
You can verify if your setup is using VLAN's by looking at the entry's in your fritzbox.

Connecting to the fiber modem is sometimes tricky. There are only straight forward connections to the modem allowed. If your router device uses a internal switch, the modem (or at least the DG) may detect this and did not offer an ip to the router.
But in most scenarios it's a reset problem. The modem, or the DG saves the mac address of your device. If you change the device, there is no connection possible.
Disconnect the router. Power off the modem. Reset the modem (press the button at least 5 seconds i.e. with a paperclip) during power on. Power off again.
Wait at least 30 minutes. Power on the modem again.
Connect the router. Wait. Enjoy

Thank you very much for your reply.
The fritzbox is mine and it was not part of the connection package. About the reset, they told me not much different, but I will check your suggestion now.
Is it possible to put it directly after the fibre optic converter without using a third party device?

Yes. It's all standard ethernet.
Never use a switch between Router & modem !!!

As you can see in my picture the modem is connected to the yellow fiber line. The R2S WAN port (OpenWrt Router) is connected via the pink cable to the modem.

And the purple cable is then LAN side of the R2S.
In my case it's a connected to the TP-Link Router. (Configured as Dumb-AP / Switch).

I did a reset as you described, then connected the router (black cable) to the converter and through my laptop (yellow cable) went into its settings. The internet is still not coming in and the IP is not being received

Hm, looks like the classic problem....

WAN is on eth0. And there are other VLAN's on eth0 too.
From DG's view there are multiple devices connected. And thats not allowed in your setup!
So remove "TETHERING" and the 2 VLAN's completely. Then try again.

Thank you very much. I'll post the results tomorrow

everything worked as you wrote.
The only thing is that the reset works a bit differently (as it turned out). You need to switch off the router, press reset on the converters for 10 seconds, let it reboot, switch it off, wait for about a minute and then switch it on and then connect the OpenWRT router.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.