OpenWrt br-lan add eth1&eth2. These two interfaces cannot be connected to the network

I compiled OpenWrt Used V21.02.3 source code.
When I add eth1 and eth2 to br-lan,these two interfaces cannot be connected to the network, and only the eth0 can be connect the network.
Please see the picture below:

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda8:75b5:4aa1::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth1'
	list ports 'eth2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '10.0.0.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth3'
	option proto 'pppoe'
	option username 'lxxxxxxxxxxx'
	option password 'xxxxxxxx'
	option ipv6 'auto'


root@OpenWrt:~# brctl show
bridge name	bridge id		   STP    enabled	interfaces
br-lan		7fff.000c2xxxxx9f	no		        eth0
							                    eth1
							                    eth2

Thanks a lot!

Everything seems correct to me... what is the issue, exactly?

1 Like

Thank you for reply!
Used eth0, I can connect the Internet. When I plug the network cable into eth1 or eth2, I can't connect to the network.Ping 10.0.0.1 is failed.Ping any domain name is also failed.

What device is running OpenWrt?

What are you connecting to eth1 or eth2? is it another computer or is it the same computer as you've connected to eth0? Is the computer set to get an address via DHCP? If so, what, if any, IP address does it get? Does the computer and/or the OpenWrt device indicate an active physical link? If not, maybe that's part of the issue -- check cables, connectors, etc.

Thank you for your reply!
1.I've tried both(same computer and another computer),only eth0 can access the Internet
2.Set via DHCP,My computer getted address is 10.0.0.156, cables plug to eth1 IP ADD is also 156,but cannot to access the Internet and ping the gateway(10.0.0.1)is also failed.
3.I used N5105 X86 machine,install ESXI,and Openwrt and NAS are installed in ESXI. eth0 is the ESXI's management interface, and eth1, eth2 and eth3 are direct network interfaces.



The system log:

Wed Jul 27 15:50:03 2022 kern.info kernel: [25427.336148] igc 0000:03:00.0 eth1: igc: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
Wed Jul 27 15:50:03 2022 kern.info kernel: [25427.337652] br-lan: port 2(eth1) entered blocking state
Wed Jul 27 15:50:03 2022 kern.info kernel: [25427.337821] br-lan: port 2(eth1) entered forwarding state
Wed Jul 27 15:50:03 2022 daemon.notice netifd: Network device 'eth1' link is up
Wed Jul 27 15:50:03 2022 daemon.info dnsmasq-dhcp[4419]: DHCPREQUEST(br-lan) 10.0.0.156 00:23:24:60:43:c8
Wed Jul 27 15:50:03 2022 daemon.info dnsmasq-dhcp[4419]: DHCPACK(br-lan) 10.0.0.156 00:23:24:60:43:c8 DESKTOP-V2H21DF
Wed Jul 27 15:50:04 2022 daemon.info netdata[3633]: Initializing file /var/cache/netdata/system.interrupts/30.db.
Wed Jul 27 15:50:04 2022 daemon.info netdata[3633]: Initializing file /var/cache/netdata/cpu.cpu1_interrupts/30.db.
Wed Jul 27 15:50:04 2022 daemon.info netdata[3633]: Initializing file /var/cache/netdata/net.eth1/main.db.
Wed Jul 27 15:50:04 2022 daemon.info netdata[3633]: Initializing file /var/cache/netdata/net.eth1/received.db.
Wed Jul 27 15:50:04 2022 daemon.info netdata[3633]: Initializing file /var/cache/netdata/net.eth1/sent.db.
Wed Jul 27 15:50:04 2022 daemon.info netdata[3633]: Initializing file /var/cache/netdata/net_speed.eth1/main.db.
Wed Jul 27 15:50:04 2022 daemon.info netdata[3633]: Initializing file /var/cache/netdata/net_speed.eth1/speed.db.
Wed Jul 27 15:50:04 2022 daemon.info netdata[3633]: Initializing file /var/cache/netdata/net_packets.eth1/main.db.
Wed Jul 27 15:50:04 2022 daemon.info netdata[3633]: Initializing file /var/cache/netdata/net_packets.eth1/received.db.
Wed Jul 27 15:50:04 2022 daemon.info netdata[3633]: Initializing file /var/cache/netdata/net_packets.eth1/sent.db.
Wed Jul 27 15:50:04 2022 daemon.info netdata[3633]: Initializing file /var/cache/netdata/net_packets.eth1/multicast.db.
Wed Jul 27 15:51:32 2022 daemon.notice netifd: Network device 'eth1' link is down
Wed Jul 27 15:51:32 2022 kern.info kernel: [25516.887429] igc 0000:03:00.0 eth1: igc: eth1 NIC Link is Down
Wed Jul 27 15:51:32 2022 kern.info kernel: [25516.887804] br-lan: port 2(eth1) entered disabled state
Wed Jul 27 15:51:41 2022 daemon.info dnsmasq[4419]: read /etc/hosts - 4 addresses
Wed Jul 27 15:51:41 2022 daemon.info dnsmasq[4419]: read /tmp/hosts/odhcpd - 0 addresses
Wed Jul 27 15:51:41 2022 daemon.info dnsmasq[4419]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Wed Jul 27 15:51:41 2022 daemon.info dnsmasq-dhcp[4419]: read /etc/ethers - 0 addresses
Wed Jul 27 15:51:41 2022 daemon.info dnsmasq-dhcp[4419]: DHCPREQUEST(br-lan) 10.0.0.156 00:23:24:60:43:c8
Wed Jul 27 15:51:41 2022 daemon.info dnsmasq-dhcp[4419]: DHCPACK(br-lan) 10.0.0.156 00:23:24:60:43:c8 DESKTOP-V2H21DF
Wed Jul 27 15:51:42 2022 daemon.info dnsmasq-dhcp[4419]: DHCPREQUEST(br-lan) 10.0.0.156 00:23:24:60:43:c8
Wed Jul 27 15:51:42 2022 daemon.info dnsmasq-dhcp[4419]: DHCPACK(br-lan) 10.0.0.156 00:23:24:60:43:c8 DESKTOP-V2H21DF
Wed Jul 27 15:51:44 2022 daemon.info dnsmasq[4419]: read /etc/hosts - 4 addresses
Wed Jul 27 15:51:44 2022 daemon.info dnsmasq[4419]: read /tmp/hosts/odhcpd - 2 addresses
Wed Jul 27 15:51:44 2022 daemon.info dnsmasq[4419]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Wed Jul 27 15:51:44 2022 daemon.info dnsmasq-dhcp[4419]: read /etc/ethers - 0 addresses

The Kernel log:

[    6.571420] kmodloader: loading kernel modules from /etc/modules.d/*
[    6.577911] e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
[    6.578074] e1000: Copyright (c) 1999-2006 Intel Corporation.
[    6.581800] i2c /dev entries driver
[    6.582961] Bridge firewalling registered
[    6.583539] e1000e: Intel(R) PRO/1000 Network Driver - 3.2.6-k
[    6.583672] e1000e: Copyright(c) 1999 - 2015 Intel Corporation.
[    6.584112] iavf: Intel(R) Ethernet Adaptive Virtual Function Network Driver - version 3.2.3-k
[    6.584307] Copyright (c) 2013 - 2018 Intel Corporation.
[    6.585767] Intel(R) 2.5G Ethernet Linux Driver - version 0.0.1-k
[    6.585908] Copyright(c) 2018 Intel Corporation.
[    6.586102] igc 0000:03:00.0: enabling device (0000 -> 0002)
[    6.667826] igc 0000:03:00.0: 128.000 Gb/s available PCIe bandwidth (5 GT/s x32 link)
[    6.668009] igc 0000:03:00.0 eth1: MAC: 60:be:b4:02:bd:ac
[    6.668203] igc 0000:0b:00.0: enabling device (0000 -> 0002)
[    6.751853] igc 0000:0b:00.0: 128.000 Gb/s available PCIe bandwidth (5 GT/s x32 link)
[    6.752037] igc 0000:0b:00.0 eth2: MAC: 60:be:b4:02:bd:ad
[    6.752239] igc 0000:13:00.0: enabling device (0000 -> 0002)
[    6.835826] igc 0000:13:00.0: 128.000 Gb/s available PCIe bandwidth (5 GT/s x32 link)
[    6.836009] igc 0000:13:00.0 eth3: MAC: 60:be:b4:02:bd:ae
[    6.839916] xt_time: kernel timezone is -0000
[    6.841915] PPP generic driver version 2.4.2
[    6.842154] NET: Registered protocol family 24
[    6.844155] kmodloader: done loading kernel modules from /etc/modules.d/*
[    8.336718] vmxnet3 0000:1b:00.0 eth0: intr type 3, mode 0, 3 vectors allocated
[    8.337405] vmxnet3 0000:1b:00.0 eth0: NIC Link is Up 10000 Mbps
[    8.337717] 8021q: adding VLAN 0 to HW filter on device eth0
[    8.338464] br-lan: port 1(eth0) entered blocking state
[    8.338589] br-lan: port 1(eth0) entered disabled state
[    8.338860] device eth0 entered promiscuous mode
[    8.339249] br-lan: port 1(eth0) entered blocking state
[    8.339371] br-lan: port 1(eth0) entered forwarding state
[    8.414195] br-lan: port 2(eth1) entered blocking state
[    8.414369] br-lan: port 2(eth1) entered disabled state
[    8.414530] device eth1 entered promiscuous mode
[    8.509794] br-lan: port 3(eth2) entered blocking state
[    8.509921] br-lan: port 3(eth2) entered disabled state
[    8.510079] device eth2 entered promiscuous mode
[    9.356406] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   11.018462] igc 0000:13:00.0 eth3: igc: eth3 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
[   11.233582] IPv6: ADDRCONF(NETDEV_CHANGE): eth3: link becomes ready
[   16.311303] pppoe-wan: renamed from ppp0
[25427.336148] igc 0000:03:00.0 eth1: igc: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
[25427.337652] br-lan: port 2(eth1) entered blocking state
[25427.337821] br-lan: port 2(eth1) entered forwarding state
[25516.887429] igc 0000:03:00.0 eth1: igc: eth1 NIC Link is Down
[25516.887804] br-lan: port 2(eth1) entered disabled state

This issue does not seem related to OpenWrt; either it is a hardware issue, or the virtualization was not configured properly.

Anyway, thanks for your reply.

When I compile with Lean's source code, everything is good.

https://github.com/coolsnowwolf/lede

It is different from the network interface configuration compiled by the official openwrt source code. Maybe I missed some options when compiling.

A post was split to a new topic: Problems adding eth1 and eth2 to br-lan on a Hyper-V VM with 22.03.5