OpenWrt as a wifi client and access point

Hi everyone,

I'm setting up OpenWrt for the first time and using a ZBT-WG3526

What I'm trying to do with the Archer is to connect it wirelessly to another router which has internet to boost the wifi signal . It should also have it's own IP-range to not really interfere with the downstairs wifi.

What I have done already is to check the interface but i cannot seems to find the repeater interface.

if anyone can point me to the right direction. my parent would be happy to get this set up for theirs camper

wifi -> scan -> join, put the link in the wan zone.

make sure the LAN subnets of the two devices don't overlap.

Thank you for your answer.i don't have wifi >>> Scan >> Join.

that doesn't look like official openwrt, you might want to reflash it based on

if you don't, we can't really help you.

Thank you for your answer. i have flashed wit the official firmware and i can connect it wit hthe exisiting networks now.
i don't know why the seller keep saying they dont advice to use the officiaal image.

you'll lose your support, I guess, assuming there's actually one ...

you helped me in 10 min, i've been contacting them for over 4 weeks and no help really.
i really appreciate it. i'll make my parents happy.
one thing i don't see other language but only auto

is it possible to add a specifique language to the system?

i appreciate your support

yes, assuming it's available ...

system -> software -> update lists

look for luci-i18n-base, and choose the language you'd like to install.

@frollic i dont know how to thank you my friend.
really appreciate it.
one last thing for today.
i noticed there updates...

Is there somewhere to schedule a update nightly or weekly?

no, it never auto updates, you have to do it manually.
you could schedule it using cron, but it's on you.

some updates might break things/configuration, which makes unattended updating suboptimal :wink:

Thank you so much.

before updating, i'll have to do some reading. but my parents are happy for now.
those updates i've shared are so far good ?
when insering the SIM it will detect the API automatically? and even doing roaming?

not sure the 3g/4g/LTE functionality comes with the image, you might have to
install additional modules (same way as the language) to make it work.
there's a LTE section in the link I posted.

probably, but I'm not 100% sure, never tried it, tbh.

create a new thread if you run into issues with the LTE.

do you probably happen to know which model i have to install for LTE Europe?
Thank you.

what kind of issues?

no idea, don't know what they ship, and it's replaceable anyway.

go to that install page, and install usbutils.

DL Putty, ssh to the IP of the router, login with the same user and pass as in the webui.
run lsusb once logged in, post the output (in a new thread).

like the one above, not really an issue, but a temp road block :wink:
this is the back side of openwrt, you have a gazillion options, but you need to be able to figure out
what you need, and how to get there ...

this the output
Bus 001 Device 002: ID 2c7c:0306 Quectel EP06-E
Bus 002 Device 001: ID 1d6b:0003 Linux 5.4.188 xhci-hcd xHCI Host Controller
Bus 001 Device 001: ID 1d6b:0002 Linux 5.4.188 xhci-hcd xHCI Host Controller

appears to be a QMI device, read the QMI section of

i am trying to install this
it keeps showing
Signature check passed nothing else.
the box is connect and online i can ping and

i noticed the device has a SIM Card reader and not a USB dongel. do i need those usb modeswitch LTE drivers?

Regarding the upgrades... don't upgrade packages unless you have a very specific reason to do so. The preferred method is to use the latest OpenWrt firmware image whenever it is updated.

Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.

QMI modems don't require modemmanager. With the QMI stack installed you can simply create an interface of proto qmi and it will start up the modem for you. This modem should automatically get the carrier's preferred APN from the SIM card, so try without setting an APN first.

And what @psherman said, if you've been using opkg upgrade you should re-flash the whole OS and start over.

Thank you so much, i'll try it monday when my parents are back.
actually the APN should detect it autmatically without have to inser it .
i have reset the box to factory settings