OpenWrt and LED settings

Hi, I have some problem with OpenWRT and LEDs on my router (Tp-link Archer C2 V3, OpenWRT version 19.07.1 stable). Sorry for my English, I hope you can understand this message.

With old factory firmware LEDs "work" had next logic:

  • If something attached to LAN port - LAN LED is ON (green light, not blinking).
  • If 2,4 or 5 Ghz Wi-fi is on - their LEDs were ON (green light, not blinking)
  • if cable is attached to WAN port and router has proper comunication with ISP - WAN LED is ON (green light, not blinking)
  • if there some problem with WAN connection - WAN LED is ON (amber light, not blinking)

With OpenWRT all LEDs are blinking. How can I restore their "old" behaviour? I tried LED settings - but all I can do - LEDs always ON, always OFF or blinking.


I am looking for solution to the same problem. Did you find it ?

Yes. I will post my scripts later today.

  1. Delete WAN LED setting in System-LED
  2. create 3 scripts in /usr/bin

ping -q -w 4 -c 1 && /usr/bin/ || /usr/bin/


/bin/echo "255" > /sys/class/leds/tp-link:green:wan/brightness
/bin/echo "0" > /sys/class/leds/tp-link:orange:wan/brightness


/bin/echo "0" > /sys/class/leds/tp-link:green:wan/brightness
/bin/echo "255" > /sys/class/leds/tp-link:orange:wan/brightness
  1. Create following task in cron:

*/1 * * * Mon,Tue,Wed,Thu,Fri,Sat,Sun /usr/bin/

Solution based on info from there: [How To] Switch on a led when internet connection is available

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.