OpenWrt 86x obstacles

My dream is to make a powerful router out of an old x86 with Wiregaurd VPN, a wireless netcard and be able to update the OpenWrt in the furture.


  1. How to find drivers for my NIC 4port netcard and install it? I guess its a package that i need. It finds the drivers with DD-wrt so the card cant be that odd. How to install?
  2. Is Wireguard easy to setup or shoud I stick to openvpn.
  3. A wireless card - can I get an asus PCI AX or is that not a good choise.
  4. How is the best why to update a X86 OpenWrt? Via SSH Command line or something else.
  1. Find the chipset with lspci and see if it is supported.
  2. In my opinion it is easier than OpenVPN
  3. If you are building a dream machine, check the Unifi access points.
  4. Web interface or SSH.
Read also about upgrading 3 lines below.

1 Like

How do I find out if its supported? And where are the package for Intel NIC? Im confussed already - I was not supposed to stop here its to early :.-)

Thanks by the way

You can download current kmod packages for x86-64 here:

to figure out what your ethernet controller is, for example:

00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (2) I218-V

Go look at the Package list:

And search for ethernet controllers...

This might be one of:

Package: kmod-e1000
Version: 4.14.167-1
Depends: kernel (=4.14.167-1-e1dd7676581672f6f0bdb1363506dee1)
License: GPL-2.0
Section: kernel
Architecture: x86_64
Installed-Size: 47884
Filename: kmod-e1000_4.14.167-1_x86_64.ipk
Size: 48658
SHA256sum: 0d8636a9a7e1cb8be1b08af5f62c7a74ce4cb898b2c646775c5845e38f9984bd
Description:  Kernel modules for Intel(R) PRO/1000 PCI Ethernet adapters.

Package: kmod-e1000e
Version: 4.14.167-1
Depends: kernel (=4.14.167-1-e1dd7676581672f6f0bdb1363506dee1), kmod-ptp
License: GPL-2.0
Section: kernel
Architecture: x86_64
Installed-Size: 75425
Filename: kmod-e1000e_4.14.167-1_x86_64.ipk
Size: 76028
SHA256sum: f1bd624bcfc01bc5d10a690b1d978b94d1b19d8782fd4ff270309a7c123e359d
Description:  Kernel modules for Intel(R) PRO/1000 PCIe Ethernet adapters.

(though I'd expect these to be included in the standard distro).

But if you have something else, just keep searching for ethernet... until you find what you guess it needs.

Once you have ethernet drivers, you can use the standard opkg tools :wink:

1 Like

I think it's a very common nic I have (the driver is there) and there is another issue because it lights up in failsafe mode. But thanks a lot for your guidance....even I understood :wink:

e1000e covers most modern Intel gigabit cards with PCIe bus interface. e1000 is for a few chips that are now obsolete and use the parallel PCI interface found on old motherboards.

In failsafe mode, with an Ethernet cable plugged in, does ip link show show the interface having a status including UP and LOWER_UP ? UP means the card is ready and LOWER_UP means that an Ethernet link is established, i.e. cable plugged in and green light on. Then try it in normal mode.

Also shortly after booting run dmesg | grep e1000e to see if the driver ever took control of the card during boot-up.

No lights but just before boot light is on - in bios mode.

Promiscuous mode - ha ha ha ha lol

So, is it working fine with the e1000e?

No it's not working ,:sob:

I'm on a second nic now and it's not working either. Open wrt is the only software that can't get the card to work - it's a joke.

I have really no idea to what this might be. Open wrt is nothing for me is the conclusion...I try to move on to open sense...I think that's the best - grrr :wink:

Second nic

You need to identify the chipset on the card. Chances are good that it simply needs the proper driver installed. OpenWrt comes with very few drivers by default.

  • Find part number stamped on the main chip of the NIC and search
  • or boot other Linux (that works out of the box with the card) and check logs or lspci -v to see which driver runs the card.

lspci -v Not found....I need to run the command somewhere else. really makes me confused. I'm lost

Assuming you have lots of space on this x86, you could just download every kmod package that could possibly be relevant, and install them all... Why waste time when space is almost free on x86 with gigs of flash?

Don't run lspci on OpenWrt, run it on a Linux that recognizes the card.

1 Like

Ispci -v I ran this command in peppermint os. But why is it a secret where the drivers are :wink: it's a very confusing :wink:

Anyway how can it be that the wan is up but no lan?

Here you are:

kmod-igb - 4.9.211-1 - Kernel modules for Intel(R) 82575/82576 PCI-Express Gigabit Ethernet adapters.

1 Like

Thanks a lot but I need some more help than this.

How du find it - because I can only find the text.

How do I install from another media I have no internet :wink:
If the board can detect a usb stick, save it there and copy it on the board.
If it doesn't have modules for the usb, then mount the flash on your pc and copy the file in /root/
Then place the flash back to the board, boot and install with opkg install kmod-igb_4.14.167-1_x86_64.ipk

1 Like

Well sometimes life is very hard. I feal so stupid. The open wrt can see my USB. But have no clue how to put on the open wrt image.
The driver is on the usb stick but it has a lock on the file after I copied it there.

second solution tried to put it inside the open wrt root section/folder with cp -i command - this does not work.

I have tried for describe it so easy but I'm too stupid to get it.

Assuming you have mounted it on say /mnt/myusb and it has some ipk files in the top directory, then on the router you simply
cd /mnt/myusb; opkg -i *ipk

Thanks! The name of my USB is /media/myname; that's correct right.

The file system is ext4 on the usb I assume it needs to be ... I will try again when I get home.