OpenWrt 23.05.0 - First stable release

The ipq40xx/generic and bmips/bcm6362 builds finished successful, see: and


Getting the below error from attended sysupgrade for ea6350v3:
Error building the firmware image

Server response: Unsupported target: ipq40xx/generic

Please report the error message and request

When i first switched from 22.03 using one of the 23.05 rc's, I only had to reset config and it worked. If you've already upgraded to a 23.05 rcx, and are upgrading to 23.05.0 ... then you don't have to do anything special.

rc4 to stable upgrade on a problems running 24hrs. Again thanks to all the Devs!!!

1 Like

The factory file is for a first installation of OpenWrt. The sysupgrade file to upgrade the installed OpenWrt version.

1 Like

Upgraded two routers: a Linksys E8450 (serving as a dumb wireless AP to the house) and a Belkin RT3200 (serving as a WDS client to one room) from 22.03.5 to 23.05.0 in two stages.

RT3200 was yesterday evening, and E8450 was early morning. I unchecked Keep Settings on both of them then flashed them... so the configs were reset and set them up again without any comprehensive notes. No issues so far.


Yes looks like 23.05.0 works well on the RT3200. All three of mine in WDS/FT arrangement work well. And my QoS stuff, samba share and rclone, and adblock-lean works well too. Thanks for your nice work developers!


EDIT: Update to this previous post.

I had another computer, so did a fresh install with a custom X86_64 build to add:

and remove mbed from build by using the - sign:

I then was able to dd the image the the drive for a fresh install.
Once booted up and logged in, I was then able to use the Luce webui to restore the backup from my old system.
There doesn't appear to be anything from the 22.x restore that conflicts. (wireless is not a factor )
Everything is up and functional on the new system. Based on this, guessing that an attendedsystem upgrade via Luci would have worked for me with my particular x86_64 configuration as long as I first installed the Openssl packages before upgrade.
I will probably test this on the old 22.x system, but am keeping it in tact for a few days as backup just in case I do notice any issues with the new one.

Sidenote: Although I went with the OpenSSL option ( to retain TLS 1.3 ) I kept the libmbedtls12 package because it is needed by https-dns-proxy.

--- Original Post ----
There are multiple posts detailing router upgrades via sysupgrade and resetting configuration. Also where attempting upgrade with retaining settings resulted in a "soft brick."

Has anyone used attendedsysupgrade on x86_64 and retained settings? I would like to attempt a 22.03.5 to 23.05.0 upgrade while retaining packages / configuration; but was first hoping to find someone having success with this scenario.

Also I would like to use OpenSSL (for TLS 1.3 ) instead of mbedtls. I've seen references to this but can't find clarification of which out of the many openssl packages are needed.
Would it be all these, (or different / more) for x86_64, with Luci and no wireless?

  1. libustream-openssl20201210
  2. luci-ssl-openssl
  3. openssl-util) ( not sure if this is needed, but the Luci package references it for key gen)

Any insight into this is appreciated. Thank you.

1 Like

Trying to build a custom 23.05 image for Linksys WHW01 (ipq40xx/generic) without ct firmware and drivers but I get the 'unsupported target' error.

You may be right.

Wait a few hours for the image builder to update its database.


I followed up on your advice, tried to figure out which packages I had added (made a small log this time...) and requested a customized build in the firmware-selector. Then I flashed this sysupgrade to my r7800.

It seems to have worked! Network and wifi came up straight after upgrading, and the router was accessible via SSH. Only thing that was weird is that Luci was apparently not installed... I then reinstalled Luci with opkg update and opkg install Luci, got some notifications about altered config files but Luci was up and running again.

It seems all is good now, thanks Devs!

Output I got:

root@Woonkamer:~# opkg install luci
Installing luci (git-23.051.66410-a505bb1) to root...
Installing luci-proto-ipv6 (git-21.148.48881-79947af) to root...
Installing luci-app-firewall (git-23.208.40260-9504081) to root...
Installing rpcd-mod-iwinfo (2023-07-01-c07ab2f9-1) to root...
Installing luci-mod-status (git-23.236.53405-9b3c7d3) to root...
Installing luci-mod-system (git-23.118.78765-58f7b27) to root...
Installing luci-mod-network (git-23.283.21598-257f54c) to root...
Installing luci-mod-admin-full (git-19.253.48496-3f93650) to root...
Installing luci-proto-ppp (git-21.158.38888-88b9d84) to root...
Installing luci-theme-bootstrap (git-23.085.34270-d94a728) to root...
Installing rpcd-mod-rrdns (20170710) to root...
Installing uhttpd (2023-06-25-34a8a74d-1) to root...
Installing uhttpd-mod-ubus (2023-06-25-34a8a74d-1) to root...
Installing luci-light (git-23.024.33244-34dee82) to root...
Installing luci-app-opkg (git-23.009.82915-ec3aac4) to root...
Configuring luci-app-opkg.
Configuring luci-mod-system.
Configuring luci-theme-bootstrap.
Configuring rpcd-mod-iwinfo.
Configuring luci-mod-status.
Configuring luci-app-firewall.
Configuring luci-proto-ppp.
Configuring luci-mod-network.
Configuring luci-mod-admin-full.
Configuring luci-proto-ipv6.
Configuring uhttpd.
Configuring rpcd-mod-rrdns.
Configuring uhttpd-mod-ubus.
Configuring luci-light.
Configuring luci.
Collected errors:
 * resolve_conffiles: Existing conffile /etc/config/uhttpd is different from the conffile in the new package. The new conffile will be placed at /etc/config/uhttpd-opkg.

Check maybe that there are some power saving enabled. I had similar issue with Wondows laptop, that was doing "too much" work on power saving :slight_smile: and afterwards the adapter could not wake properly. I gues once it is connected you do not have problems.

Can anyone suggest a solution?

Use standard sysupgrade for major version upgrades. This is the default upgrade method mentioned in the release notes:

Download firmware images via the Firmware Selector or directly from our download servers:

An upgrade from OpenWrt 22.03 to OpenWrt 23.05 is supported in many cases with the help of the sysupgrade utility which will also attempt to preserve the configuration. A configuration backup is advised nonetheless when upgrading to OpenWrt 23.05. (see “Upgrading” below).

I tried to upgrade my Raspberry Pi 4b router from OpenWrt 22.03.5 to OpenWrt 23.05.0 using the Luci Attended Sysupgrade and got the following errors. Any idea or help is appreciated.

Collected errors:
 * opkg_install_cmd: Cannot install package cypress-nvram-43455-sdio-rpi-4b.
 * opkg_install_cmd: Cannot install package luci-i18n-banip-en.
 * opkg_install_cmd: Cannot install package luci-i18n-dashboard-en.
 * opkg_install_cmd: Cannot install package luci-i18n-pbr-en.
 * opkg_install_cmd: Cannot install package luci-i18n-statistics-en.
 * check_data_file_clashes: Package libustream-mbedtls20201210 wants to install file /builder/build_dir/target-aarch64_cortex-a72_musl/root-bcm27xx/lib/
	But that file is already provided by package  * libustream-wolfssl20201210
 * opkg_install_cmd: Cannot install package luci-ssl.
make[2]: *** [Makefile:189: package_install] Error 255
make[1]: *** [Makefile:154: _call_manifest] Error 2
make: *** [Makefile:274: manifest] Error 2

It seems auc actually offers substitutions but LuCi doesn't. Or not yet ...


Exactly, how does the AUC in the LuCi technically differ from the manual installation (non-LuCi) method?

I know. I made that mistake, and tried to explain to others how to avoid making the same mistake I did :slight_smile:

Debricking equipment typically requires more knowledge, and not everyone is up for it.