OpenWrt 22.03: BT HH 5A

I tried to upgrade from 21.02.03 to 22.03 and I get this error: the device is supported, but the config is incompatible to the new image (1.0->1.1).

What should I do?
Thank you

The BT hub 5a uses DSA ethernet drivers in the 22.x branch, so the old swconfig network config is incompatible and you must not keep the settings.


You need Keep settings unticked and force upgrade ticked. I would check the sha of the image is right before clicking continue.

I'd suggest making a backup of your settings before flashing.

Also there is a boot loop issue affecting the bt hub with 22.03, which can cause it to take a fair time to successfully boot.(the first boot after update is usually fine). I found a workaround by building my own 22.03 snapshot with many packages omitted and installing them afterwards.

Thank you for your reply. So it is probably wise to wait until the boot loop problem is solved.

Probably, unless you can put up with a sometimes very prolonged time to boot, or build your own reduced size image, or install an image from some random guy on the internet (no, I wouldn't either :slight_smile: ), and then install all the missing packages using opkg after flashing, which needs a working internet connection, or a copy of all needed packages.

I would guess it should also be possible to quickly create a minimal build using the online firmware selector. I tried it using a list of custom files from the manifest of my working build, but the resultant firmware is smaller, and I didn't want to risk flashing it as I don't have the serial connections soldered on to recover it if ethernet doesn't work.

The reboot bug seems to get much worse as the image file/ kernel's size increases, I had been using the master branch since a reliable DSA patch was available with some additional large modules included in the build and started noticing random reboots shortly after the switch to the 5.10 kernel.

My current build boots reliably in about 60 seconds and I followed a guide so that I can use the official repositories. I'm guessing it could be the smaller rom image/kernel, which could explain why the bug didn't trigger reboots in previous versions, although I suppose it might be moving a specific package to the overlay.

You may want to look into an alternate router.

1 Like

So you think the bug will not be fixed?

Hopefully it will get fixed, but it sounds like it could take a lot of work, so probably quite some time even if it is. There are also several posts complaining about reduced throughput in the current build, possibly the new firewall? despite earlier performance boosts from the new DSA driver and other improvements.

Is the throughput also reduced in other devices? If not, it is a specific problem and a driver bug. I hope it will be fixed soon.

after reading the thread. I would like to try the latest version since some user have said that they have not particular problems. Is there any way to migrate my previous configuration? Which files should I remove or change from the backup?
Thank you

I think it is only /etc/config/network that has changed - although I switched to the DSA build before version 21.x came out. And only the sections relating to LAN, lan port, plus the switch stuff is gone.

I backed up my config from luci, then flashed without keeping the settings unpacked the backup with 7zip and manually copied the firewall, wireless files etc and edited /etc/config/network back to the router. You might be able to get away with restoring the backup after making the required changes to the network file in the backup and let the zip program repack it. if not failsafe mode should still work.

If it gets stuck in a prolonged bootloop at any time, sometimes disconnecting al lan cables seemed to help (might have been coincidence), but mainly just waiting and don't assume it is terminal. One of my large builds took about an hour to boot successfully, I immediately flashed a more reliable build once it did :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.