OpenWrt 22.03.2: Setup VLAN ID 7 for ISP with TP Link Archer VR200v

I just updated my VR200v to OpenWRT 22.03.2 r19803-9a599fee93 (see below)

|Hostname|OpenWrt|
|---|---|
|Model|TP-LINK Archer VR200v|
|Architecture|xRX200 rev 1.2|
|Target Platform|lantiq/xrx200|
|Firmware Version|OpenWrt 22.03.2 r19803-9a599fee93 / LuCI openwrt-22.03 branch git-22.288.45147-96ec0cd|
|Kernel Version|5.10.146|

I had to remove the configuration files (warning message, when trying to update from 22.03.0 to 22.03.2), then I tried to use my old WORKING network configuration file, which was elaborated in this thread:

After executing /etc/init.d/network restart I could not access my router anymore by LAN, so I reset it.

Then I tried to follow my own advice in the above thread, which was not working, because in LUCI there is no Network->Switch entry anymore.

My network config was/is:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'XXX/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'j'
	option tone 'bv'
	option ds_snr_offset '0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'dsl0.7'
	option macaddr 'XXX'

config interface 'wan'
	option device 'dsl0.7'
	option proto 'pppoe'
	option ipv6 '1'
	option username 'XXX'
	option password 'XXX'
	option mtu '1492'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 2 4 5 6t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t'
	option vid '7'

Your device was ported to DSA. See the Mini-Tutorial in the Wiki for details: https://openwrt.org/docs/guide-user/network/dsa/dsa-mini-tutorial

1 Like

Thanks for your advice, I have to admit, that I still do not really understand how to setup VLAN correctly (reading helped a lot, but still I dont have a clue how to move on) :frowning:
Can you help me out with my network config file?

I'm not exactly sure what you would like to achieve. If you just want to create a PPPoE connection on VLAN 7 of the DSL interface, you do not need to configure the switch. The only thing you have to change is the WAN interface (Network -> Interfaces, select WAN). I use VLAN31 with DHCP on the DSL interface, it looks like this:

Just type "dsl0.7" in your case, you won't be able to select it.

I did as you recommended, WAN device now states "Network device is not present", already checked DSL line and restarted the device...

Just to clarify: You use the VR200v's DSL modem for the connection, not an external modem, right? I just noticed that you configured the DSL interface in ATM mode, IIRC VLANs don't work in this mode.

If you use an external modem, then of course you need to configure the switch.

Yes, I connect my VR200v directly to DSL line. To make sure, the config file in my first post worked before updating.

Hm, are you on a ADSL or VDSL line?
Is your provider on this list: https://openwrt.org/docs/guide-user/network/wan/isp-configurations
What does LuCI show about the DSL status?

ADSL, no its not on the list, but Telekom Germany can be referred to. DSL Line state switches between "Silent", "Idle", "Exception"

IIRC, the dsl0 interface only appears if the modem is in sync. Since you got an "Exception", it's not synced. I'm still not convinced that you are on an ADSL line and not a VDSL line.

You configured the modem with Annex-J on ADSL, is your connection significantly faster than 20Mbps? If yes, then you could try VDSL with Annex-B as suggested in the Wiki:

config dsl 'dsl'
	option annex 'b'
	option tone 'bv'
	option xfer_mode 'ptm'

config interface 'wan'
	option proto 'pppoe'
	option ifname 'dsl0.7'
	option username 'H1und1/1234-567@t-online.de'
	option password 'abcdefghijklm'
	option ipv6 'auto'

Thanks for helping out!

Solution:

/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxx'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option ds_snr_offset '0'
        option annex 'j'
        option tone 'bv'

config device
       option name 'br-lan'                   
        option type 'bridge'                   
        list ports 'lan1'                      
        list ports 'lan2'                      
        list ports 'lan3'                      
        list ports 'lan4'                      
                                               
config interface 'lan'                    
        option device 'br-lan'            
        option proto 'static'             
        option ipaddr '192.168.1.1'       
        option netmask '255.255.255.0'    
        option ip6assign '60'             
                                               
config device                                  
        option name 'dsl0.7'                   
        option macaddr 'xxx'     
                                               
config interface 'wan'                         
        option device 'dsl0.7'                 
        option proto 'pppoe'      
        option ipv6 '1'                   
        option username 'xxx'
        option password 'xxx'           
        option mtu '1492'                      
                                               
config interface 'wan6'                        
        option device '@wan'                   
        option proto 'dhcpv6'  
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.