OpenWrt 22.03.2 second service release

Other default services (uhttpd, dnsmasq, …) listen on the wildcard interface as well and rely on firewalling for wan, I think wsdd2 should do the same.

In any case it should not be hardcoding „lan“ into the init script. Some installations might not call their lan „lan“ or have multiple downstream interfaces they wish to serve wsdd2 on.

So removing the ifname binding completely is probably the right solution after all.


Just flashed an old Ubiquiti EdgeRouter X from the factory v2.0.9 firmware to 22.03.2 using the factory image (WebUI) -> sysupgrade method without any major issues. Running rock-solid so far.

I ran OpenWrt on an ER-X used as our home network gateway for a few years and found it to be a solid improvement over stock EdgeOS. I think you'll be glad you made the change.

The only reason I'm not still using the ER-X in this role is its MT7621 CPU could not keep up with SQM after our ISP speed increased to 500 Mbps - no fault of OpenWrt. Now I'm running OpenWrt on a NanoPi R4S for our home gateway. The R4S CPU is embarrassingly underutilized :grinning:.

1 Like

if I remember correctly, there is support for hardware flow offloading on that SOC

so you can give enabling that a try (SQM must be disabled)

There is. I did experiment with hardware offloading on the ER-X with OpenWrt and it worked. The ER-X will handle Gigabit with hardware offloading, but as you noted, that requires giving up SQM.

I want to keep SQM QoS enabled on my gateway. My 500 Mbps service is with a DOCSIS 3.0 cable modem. It does not even have PIE QoS like DOCSIS 3.1.

I finally got around to upgrading my "core" EA8500, more than two months after upgrading my ea8300 satelites. I'd been putting it off due to the perceived risk of having to install the factory image to update the partition layout. I finally decided to get it over with. It took less than 10m, including the added reboot to restore my configuration.

I got an issue with the latest version. the memory usage is too high even though it is just set as an Access Point.

the biggest memory consumption according to the process page is the hostpad

Have you read the 8/64 warning?

Current OpenWrt versions, with new kernels and newer wifi drivers and newer packages and ... consume a bit more RAM and flash, so that older devices slowly get unusable.

You device is resource constrained regarding both RAM and flash.


I just red it. But i have a 128mb RAM. And it is set as an dumb AP. But still the ram is in high usage

Uhhhh... you changed devices. That said, a lot of memory seems to get used. Are you doing something unusual with these?

I run the standard "dumb AP" settings on TP-Link C7/A7's with much less memory consumption.


Hmmm, I did install the dawn and updated all the software and then made it a dumb AP and disable the firewall, ipv6, and deleted the wan Interface. that's all and deploy it as a dumb AP after a few days that happens the memory is being used by the hostapd process. in the recent version the CPU is the one who handles the process. but in this latest version, the memory is being used by the process.

I did do the reboot before. but after a few days, the memory has been consumed again.

22.03.3 is ready and able for download

1 Like

:couple_with_heart_man_man: you are always in my heart sir

Try it without dawn, I dont use it. Make sure you follow the OWT "dumb AP" instructions exactly. Maybe this dawn has a memory leak?

If it still has high memory use, there might be an issue on your hardware. Then you could file a bug report.

And yep, dave beat me to it... (im)patiently waiting till the release notice....

I'm using several Archer C7s as access points with Dawn and don't have any memory issues (only 67 MB used of 120). This access point has been up for 70 days.

FWIW, on my C7/A7 group of dumb AP's, without Dawn, typical memory use is usually 50-60ish Mb available, 40ish-50ish used. Also getting long uptimes without issues.

Just noticed this in re-reading, does that mean you did that to everything showing up in the update list? That's not recommended... see other threads on why it's not. Yes, people do it, and a lot of times it's not an issue. Other times...

Perhaps changing to the updated version of hostapd is causing the issue? I'd try again, reflashing with the stock stable release, not updating anything, and see if you still have the issue.

1 Like

OpenWrt 22.03.3 was released: OpenWrt 22.03.3 third service release