A note about using new stable releases before they are announced

There is always an excitement and enthusiasm as new stable releases start showing up on the downloads page -- and that is great! As of this moment, 21.02.3 and 19.07.10 are currently building, but they are not complete nor are they announced (current versions are still 21.02.2 and 19.07.9). Over time, the 'current' and upcoming versions will be different, but the same principles apply.

A few things to know before you try to install new versions prior to the official announcement:

  1. The build system may still be running, and it is a pretty big job. It typically takes several days for everything to complete. The official announcement will come after everything is done.

  2. Because of the fact that the builds take time, you may find that some targets/platforms are ready and others are not. This will almost always resolve with time as the build progresses.

  3. The same is true with user-installable packages -- it may appear that packages are missing, but really they just haven't been built yet.

  4. There is a relatively small chance that a problem will arise during the build process that may cause the build to fail. If this happens, the dev team may need to fix the issue and begin the build process again. Although it is quite unlikely, it is plausible that this could even include a major bug,

For all of these reasons, it is not recommended to install a new version before it is officially announced. And, if you choose to install, just remember that things are potentially still in flux, including packages you might rely on.


I couldn’t have said it better myself😃


Work perfect! Both ramips/x86 works like a magic

5 posts were split to a new topic: Upgrading Meraki MX60 to 22.03?

I would add that if you do decide to upgrade before the release announcement, make sure to backup your configuration files, and know how to recover your device (TFTP, serial) BEFORE doing the actual upgrade...in case something goes sideways.

I'd also add that quite a few have flash warnings that stop sysupgrade.

I haven't found any documentation detailing this screen yet or what to do with devices where it appears (e.g. Meraki MX60).

1 Like

With experienced Linux users, the first thing to do when seeing such warnings is to check the manpage of sysupgrade. And it is easy to spot the --force option to force an upgrade and ignore the warnings.

Windows users being Windows users; if you want to help them, the best way is to put a GUI option on LuCI.

Ummmm...these warnings say the bootloader must be edited. I doubt some Linux users could do that...especially when it's not clearly explained (i.e. what parameters in the bootloader am I to change, why, etc.).

I'm unclear on what you mean in your post by describing the force upgrade (which is documented). As I noted, there is no documentation yet; and the sysupgrade page doesn't mention it.

In fact...forcing the sysupgrade is warned against. So, I figured the next release announcement will contain the information.

I'll show a screenshot when I have the opportunity to test flashing the RC again on the MX60.

How about...I dunno...don't post the new versions anywhere until they are announced? That way, it is impossible to use them until they are announced. Problem solved.

Well the thing is that volunteer test pilots must test the release candidates in the wild before the release so we know they work.

If you simply navigate too https://downloads.openwrt.org, the release is not shown until it is announced. However, the build bots save the results onto the download server's "releases" directory which is just simply served up as a directory listing, so anyone can browse the contents there -- and people do check that directory, especially as new releases approach.

In writing my warning in the OP, I am not trying to "solve" the "problem" of users installing unannounced releases... it is to ensure that they understand the potential risks or quirks of the system. Every time a new release is in the build phase, people inevitably complain that the image for their device cannot be found, or they do manage to install and then say that packages are missing. There is a reason there is an official announcement made when each release is finished building and verified... so those who don't want to wait may encounter some issues.


4 posts were split to a new topic: LUCI wifi scan not working for 2.4 Mhz on ath79 for OpenWrt 22.03

Okay guys, maybe I found what I was looking for right up front, just ignorant-proof, basically the error must have encountered was almost certainly been mine, because I tried to install in the router to do a clean install, the latest snapshot, and I also had the same screen that you see above. I thought maybe it won't be a fully signed version yet. Well I had to do a hard reset on the second bios, which I honestly still haven't quite figured out how it works, but fortunately it saved me twice because obviously I tried the kernel first and then the upgrade.

So what's the point of my message? Well because maybe people who have a not-so-ordered life, like me, maybe forget that they don't have to install snapshot, and maybe a wording on the firmware selector page would be a great thing!

I take this opportunity to thank again very much all the people dedicated to providing us with such a well-functioning system for free. Thank you from the bottom of my heart.