OpenWrt 22.03.1 first service release

Works for me on 22.03.1.

1 Like

WRT3200ACM updated with image builder. No problems so far.

I've updated my router and 2 AP's/switches:
R7800
C2600
EAP 225 v3

All running fine, thanks for the update!

WNDR4300v1 sysupgrade no problem.

Cisco Mwraki MX60(W) - issues, see: [HOWTO] Installing OpenWrt on Cisco Meraki MX60 - #5 by NC1

WD N750 - issues, see - Update to OpenWrt 21.02.3 has destroyed my WD N750 - #27 by lleachii

there is a 1 day old report about brand new Linux WiFi vulnerabilities.

My guess is there will be a 22.03.2 SR just a couple of days away.

2 Likes

Whoa...this is quite serious...so much so, I think I'm the only one so far who will say that in English...except here:

:pray: :prayer_beads: :palms_up_together:

@jow @hnyman @aparcar - FYI to tell the developers

There is thread...

2 Likes

It's working well for me on my WRT3200ACM. Thanks for putting out another release!

TP-Link TL-MR3420 v5 OpenWrt 21.02.3 -> OpenWrt 22.03.0 -> OpenWrt 22.03.1 updated with sucsess!

[    5.895235] x86/CPU: CPU features have changed after loading microcode, but might not take effect.
[    5.913655] x86/CPU: Please consider either early loading through initrd/built-in or a potential BIOS update.

after last intel-microcode update i got this, 22.03.0 had no those messages, not even sure it's a error at all

Working great so far.
Netgear 4300V2. More than 28hours of uptime.

I'm using RPi4 and https-dns-proxy isn't working :confused: see this thread https://www.reddit.com/r/openwrt/comments/y1iyd7/help_httpsdnsproxy_isnt_working_anymore/

what is happended? why 22.03.2 released already? not even a week from 22.03.1 is 22.03.1 corrupted?

See here: https://forum.openwrt.org/t/openwrt-22-03-1-first-service-release/139424/32?u=eginnc
A new serious security issue was announced a couple days ago, and the OpenWrt developers have already tagged new stable versions to take care of it.

It is not as if we needed another reminder that the OpenWrt developers are awesome, but....well, they're awesome!

10 Likes

yeah 100% agree. They are awesome. I am eagerly awaiting the release announcement though, as this bug sounds really serious. Maybe somebody should also make a bug announcement post similar to the WolfSSL bug?

Or convert this one:

Thank you very much.

Unfortunately the problem with the USB-Port permanently resetting on Linksys MR8300 or maybe all ipq40xx platforms still exists in latest OpenWRT v22.03.01

In short, upon connecting an external usb storage device, the port keeps resetting / disables power to the device for short time leading to permanent connect / disconnect loop.

Please see Linksys MR8300, OpenWrt 22.03.0-rc4, USB port-powered storage devices not working - #29 by Barney for details. Maybe it hasn't come to the developers attention yet, since it is in another forum.

Upgraded from 21.02.02 to this version; noticed something is broken with SQM on this version - can get past 600mbit with SQM enabled. Running on i3-4160 CPU @ 3.60GHz, so not CPU bound, barley touching 15% on all cores.
When I disable SQM i get full gigabit download.
Reverted to previous version for a quick test and SQM is working fine; ingress set to 930mbit, and get around 900 on download test.

Anybody else has this problem?

EDIT:
I've been troubleshooting this for at least 3 hours, and half an hour after posting this I found the culprit; it seems the processor scaling_governor changed:
Version 22.03.1 scaling_governor: ondemand performance schedutil / schedutil is selected by default
Version 21.02.2 scaling_governor: performance powersave / powersafe is selected by default

When I change the scaling_governor to ondemand - everything works as a charm, 900+ mbit with SQM, and processor going to around 8% on all cores.

EDIT2:
Setting the minimum frequency to 1.2Ghz also does the trick

5 Likes

Your edit causes some confusion! You say 22.03.1 scaling-governor is set to "ondemand" by default and then state "When I change the scaling_govenor to ondemand -everything works as a charm". What are you changing if the default is already "ondemand"?