OpenWrt 22.03.1 first service release

https-dns-proxy isn't working for me on this release... It looks all fine, but devices cannot resolve DNS and nor can opkg.

Stopping the https-dns-proxy fixes it. Is there anywhere to report this, I'm relatively new here sorry.

Available now ?!

1 Like

Thanks. Yes, it started working about 9 hours ago -

Your screenshot wasnt the issue thought, that wasn't the issue - when you tried to make an image, it said:

I didn't take a screenshot, but it was Red and similar to this one (BTW, found from search this issue and helping others in threads before): The OpenWrt Firmware Selector - #95 by ghoffman

I thought someone would want to know a big red error screen appeared on the OpenWrt Selector, I guess not.

Completely lost me. This is exactly the obtuseness I was referencing that users may shy away from - so I will provide detail as to why I noted it. Firstly, thanks for your list - but "how to fix the OpenWrt firmware selector" - provided information beyond my control, or that others made note that a certain firmware was unavailable on the site - and they had to wait. Additionally, I already made such a web search. If there's some method for us as end users to immediately fix the firmware selector for 22.03.1 (or another release in the future), please provide a link.

If you are unaware of the problem feel free to search the forums for those who have seen that error in previous releases or needing a firmware. Thanks for your valued input.

Since the device is on some of the recent threads in the Hardware Forum, I thought I'd make a note.

I never said I didn't know how to buy a whole machine to install VirtualBox to create and install 22.03.1 - but the solution to the Firmware Selector is to wait and download it on anything (e.g. mobile devices with WiFi or an OTG Ethernet cable) and just upgrade the router. I assume like most users, we don't go to a computer store, install Hypervisors, etc. for each upgrade - if so, please provide a link on best practices to keep your machine clean, automate, it, etc. (I guess install the firmware selector - i.e. learn code on why waiting process occurs, but other threads elaborate on that, feel free to provide info on 22.03.1?).

1 Like

R7800 just updated from 21.02.3 to 22.03.1 And got the following on DAWN:

Hearing Map

Hearing Map


500 Internal Server Error
Sorry, the server encountered an unexpected error.

/usr/lib/lua/luci/template.lua:97: Failed to execute template 'cbi/map'.
A runtime error occurred: /usr/lib/lua/luci/template.lua:97: Failed to execute template '[string]'.
A runtime error occurred: [string "[string]"]:16: bad argument #2 to '?' (integer expected, got number)
stack traceback:
[C]: in function 'error'
/usr/lib/lua/luci/util.lua:49: in function
[string "[string]"]:16: in main chunk
stack traceback:
[C]: in function 'error'
/usr/lib/lua/luci/template.lua:97: in function
(tail call): ?
...usr/lib/lua/luci/model/cbi/dawn/dawn_hearing_map.lua:8: in function 'render'
/usr/lib/lua/luci/cbi.lua:266: in function 'render_children'
[string "/usr/lib/lua/luci/view/cbi/map.htm"]:6: in main chunk
stack traceback:
[C]: in function 'error'
/usr/lib/lua/luci/template.lua:97: in function
(tail call): ?
/usr/lib/lua/luci/cbi.lua:257: in function 'render'
/usr/lib/lua/luci/cbi.lua:440: in function 'render'
/usr/lib/lua/luci/dispatcher.lua:1483: in function '_cbi'
/usr/lib/lua/luci/dispatcher.lua:1056: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:483: in function

More people have a issue with DAWN after update ?

You can try reporting it over at

EDIT: also tagging @stangri if that works

Xiaomi Redmi AC2100 on MT7621, was running great on 22.03.0 for more than half a month except Luci did not show upnp mapping, but they are actually working when checking with corresponding apps.
After upgrading to 22.03.1 Luci shows upnp mapping ports correctly, but all apps begin to complain no upnp support...Tried to delete upnp lease and restart miniupnpd, no use.
any ideas?

Works for me on 22.03.1.

1 Like

WRT3200ACM updated with image builder. No problems so far.

I've updated my router and 2 AP's/switches:
EAP 225 v3

All running fine, thanks for the update!

WNDR4300v1 sysupgrade no problem.

Cisco Mwraki MX60(W) - issues, see: [HOWTO] Installing OpenWrt on Cisco Meraki MX60 - #5 by NC1

WD N750 - issues, see - Update to OpenWrt 21.02.3 has destroyed my WD N750 - #27 by lleachii

there is a 1 day old report about brand new Linux WiFi vulnerabilities.

My guess is there will be a 22.03.2 SR just a couple of days away.


Whoa...this is quite much so, I think I'm the only one so far who will say that in English...except here:

:pray: :prayer_beads: :palms_up_together:

@jow @hnyman @aparcar - FYI to tell the developers

There is thread...


It's working well for me on my WRT3200ACM. Thanks for putting out another release!

TP-Link TL-MR3420 v5 OpenWrt 21.02.3 -> OpenWrt 22.03.0 -> OpenWrt 22.03.1 updated with sucsess!

[    5.895235] x86/CPU: CPU features have changed after loading microcode, but might not take effect.
[    5.913655] x86/CPU: Please consider either early loading through initrd/built-in or a potential BIOS update.

after last intel-microcode update i got this, 22.03.0 had no those messages, not even sure it's a error at all

Working great so far.
Netgear 4300V2. More than 28hours of uptime.

I'm using RPi4 and https-dns-proxy isn't working :confused: see this thread

what is happended? why 22.03.2 released already? not even a week from 22.03.1 is 22.03.1 corrupted?