OpenWrt 22.03.0-rc6 sixth release candidate

Minor issue here.
Creating a backup archive, the proposed filename keeps the last timestamp.

Just clicked the Generate archive button and this is the result:

If I hadn't checked, I'd have overwritten my previous backup.

That's not correct, my one creates name "backup-OpenWrt-2022-08-04.tar.gz" for example
both devices x86 and 7621a

That could be browser related. Try logging out of the router in your browser, clearing cookies and site data for your router, closing the tab/window. Open a new tab and log back in and see if the file name is updated. Alternatively try a new browser that doesn't have session data for your router.

Your router might not synchronize it's time correctly.
Furthermore, browsers typically don't overwrite existing files instead a number (1) gets appended to the file name increasing with every file that has the same name.


With OpenWRT since version 21. Installed on Archer C50 V1 and V3. Working with Archer C7 V4. No problem at all.

Now the same devices with version 22.03 rc5 and rc6:

  1. Wireless Client Mode working properly.
  2. ADSL connection works fine.
  3. Dual access to the DSL Bridged modem works.
  4. Guest network in both bands tested now and are fine.

The only issue so far:
The client wireless connection (in wireless menu, below the master device) does not show the encryption method. In version 21, it displays for example CCMP AES, but now there is nothing there. It shows Encryption:-

I am sure that the encryption is WPA2 AES.

Thanks to all respective developers who have made this piece of great software. I am very happy with it and its capabilities.


1 Like

Has anyone else noticed an issue with Adblock package on rc6? This morning I noticed many weird ads on my phone and sure enough I checked Luci adblock and 'blocked domains' reported 0. I reloaded it and it's fixed, but never had that issue before, didn't happen on rc5 for example.

1 Like

Thank you,
RC6 running fine on my WRT 3200 ACM. Untill now, after 24h on RC6, didnt found any problems, also WLAN is stable for now, only thing I added, as I red in some posts here, is:

echo "0" >> /sys/kernel/debug/ieee80211/phy0/mwlwifi/tx_amsdu
echo "0" >> /sys/kernel/debug/ieee80211/phy1/mwlwifi/tx_amsdu

but dont know, if its still necessary... !?

installed is, ADBlock, WireGuard with Mullvad setup, Wireguard server to my own Homestuff Servers from which I log in to from outside connections... Transmission, SMB4, blockmount and drivers for USB attatched drives, DDNS Dynamic DNS etc...

All good, happy, and sending greetings to all those involved here with RC6 and upcomming versions for their steady work and improvements... :wave:

1 Like

Disabling amsdu has never been necessary on the wrt3200acm. Only helps targets with the 88W8864. Don't use that.

1 Like

Hi, a question on upgrading:

I am running 22.03.0-rc5, and I have been keeping current with opkg updates.
What advantage (if any) is there for me to reload with rc6? Are there features/fixes which don't come through the standard opkg updates?

Thanks - Steven

Yes, everything (incl. new security fixes) mentioned in rc6_changelog can not be obtained via regular opkg update, but only with firmware update.


Private session shown the right behavior.
Just a browser related issue. Sorry, my fault.
Thank you!

1 Like

I may be mistaken, but I thought /root/ was persistent. After updating to rc6 (and indeed also 5) my /root/ is empty.

Hi all I have rc6

Everything working great except when I run the package list update, I get the errors below. Please see all screenshots.

This is on RPi3

Everything works fine if I don't run this update. Then crashes when I do.

Very repeatable - I've done about 30 reboots in the past 1 hour

Any help appreciated

And even more specifically. The list updates. And I press dismiss after it finishes and it is this screen below where it all crashes - "Loading packages information"

Ok bizarrely seems to be a macOS Safari issue that crashes this

I just tried Firefox and works fine.

I wonder if anyone can reproduce?

try to update via putty or clear the cache of naviguator :slight_smile:

1 Like

Updating via console worked fine

Must be cache of web browser you mean?

1 Like

yes in history clear cookies etc

It works on Archer C6 EU. There is only one problem, but it may be the fault of something else, one of the computers where I test MINT, on one of the USB network cards does not connect to Wifi, it may be a problem with Mint.

Just a quick report that D-Link DIR-878 was successfully updated to 22.03.0-rc6
Upgraded via command line, not LUCI

No issues so far, but I will update if that changes.
Previous test with rc1 was a failure for me, but I'm glad that the issues were resolved!