OpenWrt 22.03.0-rc1 first release candidate

hi try traffic rules ?
in firewall

Why is that it doesnt matter whether I flash the router after a while I just cant log in to Luci. The password does contain special characters. I need to do a soft reset all the time...

No one can help you, since you have provided a grand total of zero useful information, not even a mention of the hardware you're using.

1 Like

Does it say wrong password?

Installed on TP-Link CPE220 V3 (ath79/generic) from 21.2.3. Everything seems to work except wireless scan/channel analysis. LuCI seems to freeze when starting to scan for wireless, and it takes about 20 seconds to go back to normal after refreshing webpage.

On a DIR-878, the upgrade to 22.03.0-rc1 sysupgrade, preserving configuration, was smooth.

HOWEVER, had issues that I thought I should report:

  • wired and Wi-Fi clients (both 2.4 GHz and 5 GHz) could see and connect to the router, but not communicate with the Internet
  • Connecting to the router via SSH worked, and tests (ping, traceroute) revealed that the router could see both LAN clients and WAN.
  • Suspect Firewall issue (?) but could not see anything out of the ordinary.
  • Reboots of both the WAN modem and the router itself did nothing to resolve the issue.

Unfortunately, I did not have the time to properly debug, as I am on an active system, and just wanted to test. Installing/downgrading to 21.02.3 was successful, and worked with minimal configuration adjustments.

I will need to wait until a fix is released, or documentation is updated for common upgrade steps required to get back to operational...

Installed on my Linksys WRT3200ACM via sysupgrade with no issues. Everything is working. However, my internet upload is capped at 100 Mbps on a fiber connection. I plugged my computer straight into the ONT and was able to get 900 Mbps upload.

I can't find anything configured differently from 21.02.2. Any ideas?

Is any of the systems connected directly to the router 100Mb?

If yes, try disconnecting and test. Possible bug.

3 Likes

Yes, my desktop is connected directly to the router. Everything coming out of the WAN port only allows for 100 Mbps upload. Download is good and all other devices get about 900 Mbps. The upload speed should be about 900 Mbps which works if you plug a computer directly into Verizon's fiber ONT.

So I think there is something up with a setting or the driver for the network switch in OpenWRT.

I think you misunderstood my question. Are there any ports on the router connected at 100MB instead of 1Gb? At TV perhaps? I thought I saw a bug report where if there is a 100Mb connected device, upstream drops to 100Mb on all ports.

3 Likes

Ah yes. You are correct. There was a Philips Hub bridge connected into the router and its max connection speed is 100/100. Removing it un-capped the upload speed for the router and all other devices.

I'm glad you found that bug report. I looked everywhere and couldn't find anything related. Thank you for figuring it out.

6 Likes

Works fine on Linksys EA8100 v1 except for slowness on 5G WIFI.
getting about 100+mbps instead of 200-300+mbps internet speed.

upon further checking on the local WIFI connection speed, it just connected to 5G wifi at 173mbps instead of the usual one like 300mbps to 500mbps+ (depending on my location to the router).

trying to sit beside the router and the connection still stuck at 100+mbps.

does anyone encouter the same issue?

The same is for me. The issue is with dependencies for firewall4. I created rules using nft commands from shell. It's working for now. But fw4 <=> uci configs is broken. Can't parse, can't start [zyxel_nbg6817]

Can you please PM me your firewall config triggering the problem as well as the output of fw4 flush; fw4 start ?

Sure. Couldn't find where to PM to. Could you write me sth, please?

Click on the user's avatar, then click on the Message button...


there's no

Because you just joined 30 minutes ago.

SSH in to the router and run cat /etc/config/firewall

Post the results in preformatted text, by using the icon highlighted in red...

OpenWRT Posting Icons

Repeat that process for the fw4 flush and fw4 start results.

1 Like

Or just mail him, you'll find the address in the git repos, e.g. https://github.com/openwrt/luci/commit/180d39dcd2427e3c32c0ec7ecc3c7bfb48c0d0ab.

1 Like