Openwrt-21.02.0-x86-64-generic-ext4-combined.img.gz broken somehow?

I tried downloading this file today, and writing it on a SD card for my Zotec mini-pc router. Balena Etcher complained about possible corrupted file, and wouldn't write it.

Also tried just opening the .gz with 7-zip, it complained about "there are some extra data after end of payload data" or similar error, and wouldn't open it or extract.

Does it really have a problem, or am I missing something?

openwrt-21.02.0-x86-64-generic-ext4-combined.img.gz, fresh out of the downloads page, is the file I used.

Bonus, extra question. Can I use the efi compatible one without issues, if my box isn't an EFI BIOS? (not sure, but think mine is prior to an EFI)

Forgive the dual question, I can't seem to find info about that on the OpenWrt website docs.

Image meta-data is appended behind the gzipped image, which is generally ignored (with some complaining) by sane gunzip implementations.


Ok, odd thing is, that later I find a uncompressed .img file, despite the warning. It must have taken many minutes, without any indication of working? I'd expect better of 7zip...

Also, Balena Etcher (to write the file to the SD card) typically will take a zipped or compressed file and automatically unzip it without any extra attention, and write it. But, that may apply to zipped files, not gz? I don't recall having this problem on earlier versions. Have to check and see if the compression changed on 21.02.0

Checked out a few things, the earlier OWT versions are also .gz's And, got a newer ver of Etcher, it now gives a different error msg, but still wont take the .gz and write it. Writes the img file fine.

Hmmm, might be me after all. But I sure don't remember this issue in all the earlier updates I've done with these tools. So, if I take the uncompressed .img file and write it to the disk, it should work, correct? I have to wait for an opportune moment to try this out, it's the household router, and people get touchy about outage time...

OK, was away from this issue for a while... Wrote the .img file to the SD card, did not get a working router. Am in progress with checking out if it's a SD card issue, or some such, vs some real issue with the .img

Might take a while longer with my test situation at the moment of nothing but the family router as a test bed.

Edit: FWIW, I tried using the newer (21.?) beta version of Windows 7Zip, rather than my older 18.x ver, no difference. I still get the stop at 99% extraction with box saying "There are some data after the payload data:". And, an extracted .img file in the target dir.

I went back though, and tried a 19.07.8 version of the same type of the x86 / 64 file, and 7-zip banged it right open, no hang at 99%, no error msg. So, there seems to be some kind of difference between them.

The Balena Etcher error with the gz file is their own issue and should be reported to them so they can fix it.

I have just tried to extract with 7zip (that complains about stuff after the archive) and write the same file to a USB drive with current version of Balena Etcher and then booted the drive on a PC, it seems to work fine.

Can you attach a screen to the Zotac mini PC and see if it's actually booting into OpenWrt or hanging somewhere before?

No, the EFI compatible image is only for EFI devices. If your device has been booting with the non-EFI version until now, keep using the non-efi version.

There is no other difference between them, they just boot differently to be able to run in EFI PCs.

OK, my issue, except for this sudden difference in files between 19.07.x and the 21.02.0 and its snapshot, seems to have disappeared. It may have been some hardware related issue.

I downloaded a new 21.02.0, put it on a freshly erased and formatted SD card (this has been my media choice, the Zotac happily boots from one) got family permission to do a quick 5min drop internet to test it, and as Murphy would have it, it didn't work again. OK just plug my working 19.07.7 back in.... and, nothing at all. Couldn't get anything to boot anymore.

I dig up a monitor, turns out I can get VGA terminal out, was able with earlier non working tries to see GRUB and nothing on the screen, or press key to boot medium, with no result.
I get into the BIOS, determine it's abt a 2018 version, and EFI 2.5 compatible, but I have EFI compatibility turned off. Vaguely remember having to do that, a couple years ago. Determine that it should boot from a USB drive, use Etcher to lay the img file on one, and it boots up now. Possibly my SD socket broke? I even tried another adapter for the SD to the larger mem card socket in the front of the Zotac. I don't know, just happy I got out of it.

So, looks like there isn't an issue with the image, just an oddity in unzipping the newer files, and keeping Etcher from automatically unzipping them as well. And, my hardware breaking on me at the worst possible time...

If you tried another socket and it still didn't work then the SD reader chip is dying/dead, it's not just the socket. Just put some tape over the slots to remember to never use it again.

USB shouldn't die as easily, the controller isn't a cheap third party chip but is inside the chipset (or CPU if there is no chipset).

Heh, an idea. Have an ancient scanner/printer I keep for the rare need to scan something. It's got wifi, but it's broken. About the 2nd time I went thru the whole process and troubleshooting, only to remember that again most of the way thru... I taped a note on the back of it!

I tried a different adapter, there's just one memory card socket on the box. Someday, might spend some time to see if it's recoverable, giving the pins a bend upward, checking connectors inside, etc. Was very convenient, but so is the USB.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.