OpenWrt 21.02.0 second release candidate

  • Some discussion and patches regarding mvebu architecture changes (thumb and vfpv3). You will of course have to build compile your own image.
  • From the discussion on the mwlwifi github the amsdu issue was only relevant to FW for 88W8864, and you do not want to disable if it can be avoided.
/etc/rc.local
echo "0" >> /sys/kernel/debug/ieee80211/phy0/mwlwifi/tx_amsdu && echo "0" >> /sys/kernel/debug/ieee80211/phy1/mwlwifi/tx_amsdu && logger "AMSDU Disabled"
3 Likes

Nobody has the same problem ?

Ah thank you for clearing that up with AMSDU, my WRT32X has the 88W8964 no wonder I didn't have the issue.

Hi devs,

consider disabling build for DGND3700 v2 if it cannot be fixed

I am using FritzBox 4040.
When I used OpenWrt 19.07 I not have any problems with LAN speed - it corresponded to my provider's tariff package 1 Gbps.
After update to OpenWrt 21.02 LAN speed decreased by 30% (see attached screenshots).


As I can see, for some reason in 21.02 only the first core of the processor is used to work with the network, and when its capabilities are exhausted (core gets overloaded), the speed drops.
Does anybody have the same problem?
Are there any plans to fix this?

1 Like

WPA3 working with Linksys WRT? I have WRT3200ACM and WPA3 never worked and there are no firmware updates, how it is working?

1 Like

Have you tried enabling Packet Steering? (Network -> Interfaces -> Global Network Options). Alternatively, try installing and enabling irqbalance.

2 Likes

Enabling Packet Steering didn't change anything.
But installing and running irqbalance has improved the situation significantly!

Thanks for the helpful hint! :handshake:

4 Likes

irqbalance should be used (installed and enabled) on any multi-core device (unless you assign core affinities by hand).

5 Likes

In all fairness, I have mixed WPA2psk/WPA3sae selected, but yes I have one PC that can connect to WPA3.

D-Link DIR-860L b1 here, it seems that the WiFi has blackout issue, which means when you play a online video, it's possible the playback will stop when the issue occurred.

Now upgraded back to snapshots.

Maybe this could work. Ping @jow @ynezz

Hopefully it's there by now, so opkg update and opkg install luci-app-samba4

I'm not sure if mwlwifi ever received a stable state. Marvell abandoned their upstreaming efforts and @Kaloz finally stopped developing / maintaining it.
Your problem requires some bisecting (hopefully just the mwlwifi driver) but you're probably on your own there.

Please provide output of:

  • uci get uhttpd.main.redirect_https
  • uci -c /rom/etc/config/ get uhttpd.main.redirect_https

Please also try curl -v http://192.168.0.1 on your computer and provide the output.

Please provide a screenshot.

Runtime removal of packages shipped with release won't free any space as they are part of squashfs filesystem that can't be modified. Removing only marks such files (pre-shipped) as deleted and "hides" them. Use ImageBuilder to build your customized firmware.

Please try some recent snapshot again. It that problem still occurs, please provide a full error message. If that is about luci-app-samba4 then it may be fixed by now (some people in this thread confirmed that).

Those names come from Linux kernel which takes them from .dts files. I believe upstream convention is to name ports as they are labeled.
We could rename default L3 interface from lan to something like localnetwork but that would be terribly confusing and against all existing documentation.

Your updated config looks totally fine to me. So what exactly happens? Please provide output of ifconfig -a and brctl show.

Please provide output of the ls /sys/devices/platform/1e140000.pcie/pci0000:00/0000:00:01.0/

@nbd: what's the state of mt76 in the 21.02 branch / rc2 release?

3 Likes

with the proper linksys wrt wifi was working good 866MBit.
now since v21 it is not working with RDP, stop videos on facebook, something changed.

@jow has found another report which may suggest some software regression indeed. Please check 21.02.0-rc2 WRT3200ACM wireless is broken and help debugging that problem further in linked topic.

2 Likes

yes this is what i am talking about. it looks like the problem with mwlwifi is since kernel above 5.3

I would assume that 21.02 will stay on a 5.4 kernel. Of course the third number will change for the final release or any upcoming release candidates.

@rmilecki on Totolink x5000r configuration autogenerated with "wifi config" doesn't work correctly
I filled bug report at https://bugs.openwrt.org/index.php?do=details&task_id=3856 and added output of 'ls'

Upgraded FRITZ!Box 7530 from RC1 without no issues however only issue i have is my FRITZ!Box 7530 LAN ports are not configured propley For example LAN 1 is LAN 4 and LAN4 is LAN1 but not sure if this was in other versions of OpenWrt.@rmilecki @jow i completed factory resetted the FB but issue still there

@YuriPet - What FRITZ!Box do you own for the near 1G service? and do you use PPPoE or WAN?

I use the FRITZ! Box 4040 and DHCP wired connection with provider.

[PATCH] ipq40xx: specify FritzBox 7530 LAN port label numbers

3 Likes