OpenWrt 21.02.0 doesn't boot on D-Link DIR-885L/DIR-890L

I tried installing the D-Link DIR-885L image onto the DIR-890L (openwrt-21.02.0-bcm53xx-generic-dlink_dir-885l-squashfs.bin) and the router went straight to D-Link Recovery mode (

I install the previous release image (19.07.8) without any issues (openwrt-19.07.8-bcm53xx-dlink-dir-885l-squashfs.bin).

Has anyone tried this router with the latest release?
Do I need to connect the serial port to get some logs?

I have installed 21.02.0 on a 885L A2 without any issues. I do not recall if I installed it twice as I was doing other things at the same time. Strange that you got back to recovery without pressing with a pin for 10s. Try installing it a second time.

I tried more than once. It's good to know that at least someone can run it. It might be a small change required somewhere but for now I will stick to 19.07.x.

I have this Model DIR-890L. Now using DD-Wrt. Is this model can flash the image openwrt-19.07.8-bcm53xx-dlink-dir-885l-squashfs.bin ?

No, you can't.

I have a DIR-885L A2, and as noted above, loading a new image sends my router to D-Link Recovery mode as well. I can load the new image from recovery mode, but this process erases the configuration.