OpenWrt 19.7.5 and 802.1q VLAN

Hello,
i have a Compex WPJ419 Board with OpenWRT 19.7.5 (today compiled)

My Network on eth1 works fine on an untagged network switch.

I would like to enable 802.1q Support on my eth0

DMESG shows

8021q: 802.1Q VLAN Support v1.8

I configured a tagged VLAN on eth1, locally the IP on board is reachable, but other network devices are not reachable

If i restart my network (over UART) i see, that there is no 802.1q Support on Network
(the message "8021q: adding VLAN 0 to HW filter on device eth0" is not shown)

How can i enable 802.1q Support on my network ?

Thank you very much and best regards
Joerg

Give output of uci export network, or /etc/config/network

Hi, here is my output from my file /etc/config/network

config device
        option type '8021q'
        option ifname 'eth0'
        option vid '1101'
        option name 'vlan1'

config device
        option type '8021q'
        option ifname 'eth0'
        option vid '1102'
        option name 'vlan2'

config device
        option type '8021q'
        option ifname 'eth0'
        option vid '1103'
        option name 'vlan3'

config interface 'lan1101'
        option type 'bridge'
        option ifname 'vlan1'
        option proto 'static'
        option ipaddr '192.168.1.20'
        option netmask '255.255.255.0'


config interface 'lan1102'
        option type 'bridge'
        option ifname 'vlan2'
        option proto 'static'
        option ipaddr '192.168.2.20'
        option netmask '255.255.255.0'

config interface 'lan1103'
        option type 'bridge'
        option ifname 'vlan3'
        option proto 'static'
        option ipaddr '192.168.3.20'
        option netmask '255.255.255.0'

On CompexWRT the configuration is working, but i want to use OpenWRT.

Thank you and Best regards
Joerg

Have you tried:

without the config device part?

IPQ40xx Switch Config "Strangeness" should apply.

Thank you for the information. I'll try it recompiling the kernel. On Openwrt 19.07.4 everything works fine with vlan and this board, but on 19.07.5 it doesn't work :frowning: