Openwrt 19.07 RC1 Archer C7 V2 5G wifi died after trying to change channels

So I flashed 19.07 on to 18.06.04 with sysupgrade image changing firmware to ath79. After a while I spotted that my laptop is no longer connecting with 80mhz width. So I tried changing channels. Then my 5G wifi died. I flashed again 19.07 RC1 this time factory image. Still 5G wifi is dead. I set WPA3-SAE / WPA2-PSK mode. Used hostapd-openssl package.


Also I tried switching "Allow legacy 802.11b rates" off for fixing channel width. If I recall correctly this with changing channel resulted in 5G dying.

System Log
Kernel Log

Did you already recreate /etc/config/wireless?

ar71xx and ath79 refer to the wireless chips differently, as I recall.

1 Like

I'm using LuCi so I was not editing configuration files directly. But I configured it from scratch after upgrading from 18.06.04.


how about using mainline ath10k for final releases and ath10k-ct for snapshots only as a default?

Are you sure thats good thread? It looks like you refer to something different.

can you try to uninstall ct version of both driver and fw and install regular version?

I have uninstalled ct versions and installed "ath10k-firmware-qca988x" and "kmod-ath10k" packages. After reboot 5G waked up but still only 20 mhz channel. Where on 18.06 I had working 80mhz. My laptop has Intel AX200 card.


I switched on Windows to WPA3 from WPA2. But I don't know if that is a reason cause I didn't checked channel width before that.

that might be due to recent mac80211 changes. try switching channel to 48.

Changed from 36 to 56. Now changed to 48. Width still 20 mhz.

does forcing 40Mhz mode from wifi settings help?

Still 20 mhz width after forcing. I've also checked it against speedtest if thats only wrong reading. But I get around 10Mbits on 600 Mbits fibre. So it is 20 width.

what does the info in luci displays? vht, ht or legacy mode/rates?

Sometimes it will show
"72.2 Mbit/s, 20MHz, MCS 7, Short GI
48.0 Mbit/s, 20MHz"

looks like your both interfaces operate at legacy rates, try switching to wpa2 only to see if wpa3 causes any regression

Nope. Still 20 mhz width. Changed to WPA2-PSK only and rebooted.


For short moment I saw 40mhz width connection in LuCi. For like 5 sec.

Are you sure it's not on a DFS channel and your region settings are correct?

Changed country from US to correct one. Still 20. There is almost no 5G wifi in my area. So channels are free. I'm trying on 48 channel. From time to time I can see in LuCi 40 width for short moments. After that back to 20. Also I'm like 2 meters from router so it's not range problem.

Doesn't matter if there's no interference, sometimes DFS has to listen for a period of time before any broadcast can happen. Run dmesg or logread and you should see whether or not DFS is listening.


pdev param 0 not supported by firmware
and in logread
Mon Nov 11 00:07:16 2019 daemon.notice hostapd: 20/40 MHz operation not permitted on channel pri=11 sec=7 based on overlapping BSSes

Seems like this combo is not allowed by your regulatory domain (PL). Maybe try another channel?