OpenWrt 19.07.5 service release

Upgraded my 4040 just now, this time it went well: I guess bug 3239 may be closed, right?

upgraded my xiaomi r3p a few days ago, became unstable (constant high load even though it wasn't doing anything special -- i.e., only doing things that worked fine on 19.07.3).

I think the -CT drivers need to be switched to the normal or small buffers drivers for this router. I get way better performance when I switch to the normal drivers manually.

Do you have a link with more on that?

Yes ;- )

No longer pending. Install and configuration as router, firewall and WAP with HTTPS for luci was without problem. Loaded openwrt-19.07.5-ath79-generic-tplink_archer-a7-v5-squashfs-factory.bin straight from the TP-LINK firmware.

Yes, I do.

Upgraded BT Home Hub 5A on AP keeping previous settings but only getting WAN speed 70Mbps. Getting 122Mbps on 19.07.4.

Works great with TP-Link Archer C50 v4.20 !

Just had to patch mt76's kernel with

This has been committed on the master branch

Thank you ! :slight_smile:

This router's performance was bad on TP-Link firmwares, either a version had problems with 2.4ghz or other one was 5ghz, with OpenWrt, it is really reliable and works great with streaming services. For a wireless router which cost 30$ USD, it is good I can install OpenWrt on it!

Upgraded TP-Link C58 from latest snapshot to 19.07.5 and fixed most of problems like 4WAY_HANDSHAKE_TIMEOUT on low signal, 5g reboot on heavy data transfer, router running smoother and stable and finally system upgrade from luci works again without bricking my router.


ath79/generic tplink archer a7 v5 (used as dump AP): successfully upgraded from 19.07.3

ramips/mt7621 zbt-wg3526-16M (router): lock ups on 19.07.5, possibly related to, reverted to 19.07.3

On EA/MR8300 also, 10MB more ram used and increasing as days go by..

this issue exist on all Mediatek chipset

I have 3 router on 2 different manufacturers 2 from xiaomi which is Xiaomi Router 4a 100M and the Gigabit edition also Newifi3 d2.

all 3 routers exhibit this rouge RAM hogging kind of issue. doing TOP doesnt reflect the actual RAM usage, from TOP it only report around 60+Megs of ram usage on running background while in system information from luci it reports around 200+MB or RAM usage based on newifi3 d2 which comes with 512megs of RAM. Both xiamo router 4a (100m and gigabit edition) will crash for about 3-7 days and reports for Out of Memory when access luci webpage. newifi3 d2 will take around 1-2months before it gets the same Out of Memory isssue.

Hi folks,

I've upgraded my r7800 to 19.07.05 and now it crashes every several days. Machines connected via ethernet can still communicate, but is unreachable and wifi is dead. I have to powercycle router to restore operations.

I tried to find any guidelines on troubleshooting but failed :(. Please advise what I can try.


Package downloads failing...

Collected errors:
 * opkg_download: Failed to download, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download, wget returned 8.
 * opkg_download: Failed to download, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download, wget returned 8.

Please read the error message and fix your network connectivity.

wget returned 4.
 * opkg_download: Check your network settings and connectivity.

Possibly your router does not have proper DNS or gateway (if it is not using DHCP)

Works fine here, did you check the network as suggested?

In fact I had to do the following to get it to work again. It appears as though for some reason the URL is not allowing HTTP and even redirects me when I type it manually into the browser of Chrome...

I downloaded all of these manually:

Then I copied them using WinSCP to the router and installed them manually:
opkg install ./ca-bundle_20200601-1_all.ipk ./ca-certificates_20200601-1_all.ipk ./libmbedtls12_2.16.8-1_arm_cortex-a9_vfpv3-d16.ipk ./libustream-mbedtls20150806_2020-03-13-40b563b1-1_arm_cortex-a9_vfpv3-d16.ipk

Then it worked.

@bjonglez This redirection has been set up on the web server will not work because people do not have the SSL packages installed and you have set up a permanent redirect to a HTTPS resource. This is a server side issue and an issue with how the OpenWrt package is delivered without HTTPS support.

PS C:\Users\craig> Invoke-WebRequest -MaximumRedirection 0

StatusCode        : 301
StatusDescription : Moved Permanently
Content           : <html>
                    <head><title>301 Moved Permanently</title></head>
                    <body bgcolor="white">
                    <center><h1>301 Moved Permanently</h1></center>

RawContent        : HTTP/1.1 301 Moved Permanently
                    Connection: keep-alive
                    Content-Length: 185
                    Content-Type: text/html
                    Date: Mon, 11 Jan 2021 11:29:55 GMT
Forms             : {}
Headers           : {[Connection, keep-alive], [Content-Length, 185], [Content-Type, text/html], [Date, Mon, 11 Jan 2021 11:29:55 GMT]...}
Images            : {}
InputFields       : {}
Links             : {}
ParsedHtml        : mshtml.HTMLDocumentClass
RawContentLength  : 185

Invoke-WebRequest : The maximum redirection count has been exceeded. To increase the number of redirections allowed, supply a higher value to the -MaximumRedirection parameter.
At line:1 char:1
+ Invoke-WebRequest ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-WebRequest], InvalidOperationException
    + FullyQualifiedErrorId : MaximumRedirectExceeded,Microsoft.PowerShell.Commands.InvokeWebRequestCommand

It's not an issue as it works as expected. You need to change your user agent to uclient-fetch if you want to download over HTTP.

1 Like