OpenWrt 19.07.4 service release

Weak wifi signal on WNDR3700 v1 in previous version (see other post) is solved in OPENWRT_19.07.4-ath79. Now an excellent wifi signal strenght in 2.4Ghz and 5Ghz bands.
Thanks!. All other functions that I use in my custom build like Wireguard, OpenVPN, Adblock, DynamicDNS, Wifi Schedule, Wake on LAN, Network Shares, SQM QoS, LED configuration, BandWith Monitor and uHTTPd work perfect!
I could upgrade from OPENWRT_19.07.3-ar71xx to OPENWRT_19.07.4-ath79 while I could not upgrade to OPENWRT_19.07.4-ar71xx, but in my case ath79 was the route to go anyway. :grinning:

Many Thanks to all volunteers working on OpenWRT. what a perfect piece of open source sofware with high quality. :clap:

I have upgraded my HomeHub 5.0 from 19.07.3 to 19.07.4 and my ac WiFi radio stopped working completely.
On Luci it says Qualcomm Atheros QCA9880 802.11nac “Device is not active”. Restarting it does not change the status
Edit: installing wpad-openssl fixed it

Just upgraded Linksys MR8300 to 19.07.4 using EA8300 factory.bin. I used Advanced Reboot, thanks to Flashing OpenWrt on Linksys MR8300 - partially bricked, luci module to boot back into OEM partition and reinstalled factory.bin with http://routeripaddress/fwupdate.html web firmware uploader and reconfigured once rebooted.
All is working fine !
Many thanks to Dev Team !

Edit: Also upgraded Linksys EA8300, booted from OEM partition, upgraded with factory.bin, reconfigured, all is fine.

Upgraded EdgeRouter X to 19.07.4 from 19.07.3 with keep settings. No issues after 3 days of run time as the home network gateway taking care of SQM; Adblock; DHCP for LAN, Guest and IOT VLANs; and two wired AP's.

Thank you Developers!

1 Like

What is the max speed can you achieve with SQM?

EdgeRouter X running OpenWrt 19.07.4 with layer CAKE SQM, ECN "on" for both ingress and egress; Ethernet with 22 Byte per packet overhead link layer adaption; DOCSIS 3.0 cable ISP:

Edit - for completeness, this is what I get without SQM:

Edit 2 (Dec 2022):
My ER-X CAKE performance dropped by almost half with OpenWrt releases after ramips conversion to DSA. Near 200 Mbps SQM performance can still be achieved on 22.03.x using fq_codel/simple instead of CAKE on MT7621 with irqbalance spreading the load across the 4T/2C MT7621 CPU, and I still found DSA OpenWrt releases to route faster than stock EdgeOS, but the days of phenomenal pre-DSA conversion performance may be gone for good.


Just upgraded my Linksys WRT1200AC from .3 to .4 and everything works fine. It also fixed the ability to reboot from Luci where in .3 it often had issues. Now it's perfect. Keep up the awesome job Devs!!!

Congrats on the release. Running well on my Meraki MR33 which is running as an AP on the network.

I confirm. Me too, I upgraded with success! :smiley:
Thanks for all devs! :partying_face:

And the "Hardware flow offloading" option seems to be functionnal, even for others interfaces, than LAN. :stuck_out_tongue:

Please keep this discussion on-topic. The ER-X does not have 4g (or any radio) hardware, so this is irrelevant to the 19.07.4 announcement thread.

Thanks for this valuable upgrade. I upgraded two Sitecom WLR-8100 routers from 19.07.3. The one that was configured as router needed it's interface to the fiber (WAN) make a forced connection or it would not connect and I needed to re-install the luci app for SQM (the config was still intact though). The other one is just an extra AP two floors up: no changes needed: upgraded, rebooted and just worked again.

I noticed the 19.07.4 is slightly more memory efficient. And Luci is more responsive, although the latter can also be just my mind wishing that :wink:

Both 19.07.3 and 19.07.4 work great for the Sitecom WLR-8100. I have both hardware revision (v1.001 and v1.002). The PCB's are identical visually, except for the caps (which I replaced by high quality ones btw). So I suggest the WLR-8100 v1.002 it is safe to move this version from snapshot to mainstream stable.

The v1.002 is running as my router and (so far) never needs rebooting because of a software/settings issue.

Keep up the good work!

1 Like

Thank you for great work.

Awesome job guys!

I upgraded my Mikrotik RB750GR3 from 19.07.3 to 19.07.4 with keep settings, but so far it seems to be somewhat unstable. I get random reboots multiple times a day. The previous version easily got up to 40+ days uptime.

I'm seeing the same problem on an Asus RT-N56U wireless router and have appended a little more information to the bug report.

1 Like

My issue is not really the same, my router completely reboots (uptime resets etc).
In the linked bug report the router stays up but drops packets.

1 Like

Yes, I have the same problem "mtk_soc_eth 10100000.ethernet eth0" on my Asus RT-N56U (Ralink RT3883 ver:1 eco:5).

Yes, my Asus RT-N56U (Ralink RT3883 ver:1 eco:5) sometimes reboots and I have no way to refer to the system or kernel logs to troubleshoot the error.

Small correction, uptime resets, but the bootlog times stay the same, it just resets after the whole bootup sequence (everything between bootup and (soft)reboot disappears from system log.
Because the stability of this router is somewhat important to me i decided to revert to 19.07.3 for now.
The hangs / crashes / reboots are very visible on my memory statistics charts.

Upgraded Linksys EA8500 from .3 to .4, noticing some wifi drops and LAN drops... other than that all ok

In Open Source this aproach is commen

"Its ready when its ready"