Openwrt 19.07.4 and wireguard

Hi, everybody
I have configured wireguard as a server on the router. Saved, attached, and restarted.
The connection from the PC to the router worked.
In the settings, of course, I had also entered the peers.
The next time I looked at the configuration of the peers, these entries were no longer available, only wg0 and the configuration of the server was available.
Is that normal?
Thank you and greetings

Are you saying no status, or the config is missing?

And no, it's not normal to save a config and it turns up missing.

The Config is missing.
Here is the Status:

Under peers, two pieces of configuration would have to be visible.

I have re-entered the configuration and now it is visible!

For this I do not get contact to the openWRT via the Internet address of the router. (router cascade)
The router (Fritzbox 7590) has a public web address and a ping on this address gets a response. I also use other services that run through this address. So that works. In the 7590 I set up a port forwarding to the Fritzbox 4040 with openWRT on it (as for the other service as well).
How can I check now whether the port forwarding in the 7590 to the 4040 works with openWRT?
2 PC in the LAN now get a connection to the wireguard server on the openwrt with its LAN address. If I change this address on the PC to the DYN DNS address (Internet address) of the router 7590, no connection will be established.
If wireguard is addressed directly from the LAN on the openWRT, it works, the packets come from the Internet via the 7090 there is no connection.
I have the instructions for setting up the wireguard on openWRT from the C't Magazine: "Set up VPN with openWRT for beginners"
Who knows Council?

I have solved the problem!
In addition to the settings in the openWRT, according to the instructions, I created a port forward from wan to the NAT rule of wireguard and the server IP of wireguard on the openWRT and access via the Internet worked immediately.
Thank you and best regards

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.